Firmware Update failed " [00606769]Packet upgrade failed at last version checking, Ret = -1. "

Joined
Oct 20, 2017
Messages
17
Reaction score
0
Age
27
I tried upgrading my firmware today to P3C_FW_V01.09.0200. Unfortunately it failed. Does anybody know what [00606769]Packet upgrade failed at last version checking, Ret = -1. means?
Remote was not connected.

Before the update I've been having issues with my video and telemetry transmission from the drone to my remote.

This is the log:

[00006561]========== Upgrade: remo-con disconnect. boot(66E7)============
[00006755]Packet [C:\P3C_FW_V01.07.0800.bin] detected, card sn [0x80b34224].
[00006853]Packet upgrade start...
[00006953]Packet checking...
[00007094]Packet vlink 01.07.0800 <-> 01.07.0090.
[00007190]Done.
[00007289]Version checking[1]...
[00007448][04 00][00] v1.51.0.0 -> v1.51.0.0 need upgrade.
[00007651][11 00][00] v2.0.0.32 -> v1.8.0.0, firmware v2.0.0.32 not support.
[00007749][11 00][00] v2.0.0.32 -> v1.8.0.0
[00007952][11 01][00] v2.0.0.32 -> v2.0.0.33 need upgrade.
[00008233][03 05][00] v34.2.0.9 -> v34.2.0.9 need upgrade.
[00008415][03 06][00] v2.4.20.28 -> v2.4.20.28 need upgrade.
[00016109][07 00][00] v1.0.9.62 -> v1.0.9.62 need upgrade.
[00016278][09 00][00] v0.1.1.0 -> v0.1.1.0 need upgrade.
[00016512][12 00][00] v5.9.0.0 -> v5.9.0.0 need upgrade.
[00016704][12 01][00] v5.9.0.0 -> v5.9.0.0 need upgrade.
[00016911][12 02][00] v5.9.0.0 -> v5.9.0.0 need upgrade.
[00017104][12 03][00] v5.9.0.0 -> v5.9.0.0 need upgrade.
[00017352][29 00][00] v2.4.1.212 -> v2.4.1.231 need upgrade.
[00017502][29 01][00] v2.4.1.212 -> v2.4.1.231 need upgrade.
[00017600]Done.
[00019697]Waiting for user confirm...
[00029795]Timeout, start upgrade automatically.
[00029990]Firmware upgrading[1]...
[00034563][29 00] Firmware upgrade start...
[00034664][01 00] Firmware upgrade tracecode 0x00010000
[00034776][01 00] Firmware upgrade tracecode 0x00020000
[00036889][01 00] Firmware upgrade tracecode 0x00030000
[00036993][01 00] Firmware upgrade tracecode 0x00040000
[00049868][01 00] Firmware upgrade tracecode 0x00050000
[00049968][01 00] Firmware upgrade tracecode 0x00060000
[00050065][01 00] Firmware upgrade tracecode 0x00070000
[00101390][01 00] Camera firmware programed successfully.
[00012113][01 00] Firmware upgrade finished successfully.
[00012211]Done.
[00012312]Packet [C:\P3C_FW_V01.07.0800.bin] resumed, card sn [0x80b34224].
[00012421]Packet vlink 01.07.0800 <-> 01.07.0090.
[00012615]Version checking[2]...
[00012780][04 00][00] v1.51.0.0 -> v1.51.0.0 need upgrade.
[00013009][11 00][00] v2.0.0.32 -> v1.8.0.0, firmware v2.0.0.32 not support.
[00013112][11 00][00] v2.0.0.32 -> v1.8.0.0
[00013373][11 01][00] v2.0.0.32 -> v2.0.0.33 need upgrade.
[00013673][03 05][00] v34.2.0.9 -> v34.2.0.9 need upgrade.
[00013869][03 06][00] v2.4.20.28 -> v2.4.20.28 need upgrade.
[00014048][07 00][00] v1.0.9.62 -> v1.0.9.62 need upgrade.
[00014216][09 00][00] v0.1.1.0 -> v0.1.1.0 need upgrade.
[00014464][12 00][00] v5.9.0.0 -> v5.9.0.0 need upgrade.
[00014668][12 01][00] v5.9.0.0 -> v5.9.0.0 need upgrade.
[00014886][12 02][00] v5.9.0.0 -> v5.9.0.0 need upgrade.
[00015076][12 03][00] v5.9.0.0 -> v5.9.0.0 need upgrade.
[00015324][29 00][05] v2.4.1.231 -> v2.4.1.231 need upgrade.
[00015474][29 01][00] v2.4.1.212 -> v2.4.1.231 need upgrade.
[00015572]Done.
[00015669]Firmware upgrading[2]...
[00016633][29 01] Firmware upgrade start...
[00016733][01 01] Firmware upgrade tracecode 0x00010000
[00016830][01 01] Firmware upgrade tracecode 0x00020000
[00016929][01 01] Firmware upgrade tracecode 0x00030000
[00017032][01 01] Firmware upgrade tracecode 0x00040000
[00017151][01 01] Firmware upgrade tracecode 0x00050000
[00017304][01 01] Firmware upgrade tracecode 0x00060000
[00017453][01 01] Firmware upgrade tracecode 0x00070000
[00017569][01 01] Camera loader update successfully.
[00047666][29 01] Firmware upgrade finished successfully.
[00048962][07 00] Firmware upgrade start...
[00086777][07 00] Firmware upgrade finish without reboot.
[00116877][07 00] Firmware upgrade finished successfully.
[00117828][12 00] Firmware upgrade start...
[00156223][12 00] Firmware upgrade finished successfully.
[00157175][12 01] Firmware upgrade start...
[00195548][12 01] Firmware upgrade finished successfully.
[00196501][12 02] Firmware upgrade start...
[00234728][12 02] Firmware upgrade finished successfully.
[00235682][12 03] Firmware upgrade start...
[00274153][12 03] Firmware upgrade finished successfully.
[00275108][11 01] Firmware upgrade start...
[00333943][11 01] Firmware upgrade finished successfully.
[00334900][03 05] Firmware upgrade start...
[00420304][03 05] Firmware upgrade finished successfully.
[00421331][03 06] Firmware upgrade start...
[01260110][03 06] Firmware upgrade finished successfully.
[01261067][09 00] Firmware upgrade start...
[01290895][09 00] Firmware upgrade finish without reboot.
[01320992][09 00] Firmware upgrade finished successfully.
[01321951][04 00] Firmware upgrade start...
[01382224][04 00] Firmware upgrade finished successfully.
[01382325]Done.
[01382422]Version checking[3]...
[01382584][04 00][05] v1.51.0.0 -> v1.51.0.0 need upgrade.
[01382798][11 00][00] v2.0.0.33 -> v1.8.0.0, firmware v2.0.0.33 not support.
[01382896][11 00][00] v2.0.0.33 -> v1.8.0.0
[01383101][11 01][05] v2.0.0.33 -> v2.0.0.33 need upgrade.
[01383381][03 05][05] v34.2.0.9 -> v34.2.0.9 need upgrade.
[01383574][03 06][05] v2.4.20.28 -> v2.4.20.28 need upgrade.
[01383787][07 00][05] v1.0.9.62 -> v1.0.9.62 need upgrade.
[01383949][09 00][05] v0.1.1.0 -> v0.1.1.0 need upgrade.
[01384177][12 00][05] v5.9.0.0 -> v5.9.0.0 need upgrade.
[01384369][12 01][05] v5.9.0.0 -> v5.9.0.0 need upgrade.
[01384576][12 02][05] v5.9.0.0 -> v5.9.0.0 need upgrade.
[01384768][12 03][05] v5.9.0.0 -> v5.9.0.0 need upgrade.
[01385016][29 00][05] v2.4.1.231 -> v2.4.1.231 need upgrade.
[01385167][29 01][05] v2.4.1.231 -> v2.4.1.231 need upgrade.
[01385267]Packet upgrade finish successfully.
[00012674]========== Upgrade: remo-con disconnect. boot(1FF7)============
[00012779]Packet [C:\P3C_FW_V01.09.0200.bin] detected, card sn [0xda6ad315].
[00012879]Packet upgrade start...
[00012986]Packet checking...
[00013086]Packet vlink 01.09.0200 <-> 00.00.0000.
[00013185]Record vlink 01.07.0800 <-> 01.07.0090 (flow = 0).
[00013285]Done.
[00013386]Version checking[1]...
[00013636][04 00][00] v1.51.0.0 -> v1.51.0.0
[00026284][11 00][00] device not detected.
[00038932][11 01][00] device not detected.
[00051682][03 05][00] device not detected.
[00064331][03 06][00] device not detected.
[00076979][07 00][00] device not detected.
[00077142][09 00][00] v0.0.0.0 -> v0.1.1.1 need upgrade.
[00089790][12 00][00] device not detected.
[00102439][12 01][00] device not detected.
[00115086][12 02][00] device not detected.
[00127735][12 03][00] device not detected.
[00127985][29 00][00] v2.4.1.231 -> v2.4.1.231
[00128137][29 01][00] v2.4.1.231 -> v2.4.1.231
[00128234]Done.
[00130334]Waiting for user confirm...
[00140436]Timeout, start upgrade automatically.
[00140635]Firmware upgrading[1]...
[00141606][09 00] Firmware upgrade start...
[00165801][09 00] Firmware upgrade finish without reboot.
[00195902][09 00] Firmware upgrade finished successfully.
[00196007]Done.
[00196108]Version checking[2]...
[00196286][04 00][00] v1.51.0.0 -> v1.51.0.0
[00196525][11 00][00] v1.8.0.0 -> v1.8.0.0
[00196786][11 01][00] v1.8.0.0 -> v2.0.0.33, firmware v1.8.0.0 not support.
[00196886][11 01][00] v1.8.0.0 -> v2.0.0.33
[00197182][03 05][00] v34.2.0.9 -> v34.2.0.9
[00197366][03 06][00] v2.4.20.28 -> v2.4.20.50 need upgrade.
[00210020][07 00][00] device not detected.
[00210188][09 00][05] v0.1.1.1 -> v0.1.1.1
[00210402][12 00][00] v5.9.0.0 -> v5.9.0.0
[00210604][12 01][00] v5.9.0.0 -> v5.9.0.0
[00210805][12 02][00] v5.9.0.0 -> v5.9.0.0
[00211023][12 03][00] v5.9.0.0 -> v5.9.0.0
[00211272][29 00][00] v2.4.1.231 -> v2.4.1.231
[00211421][29 01][00] v2.4.1.231 -> v2.4.1.231
[00211525]Done.
[00211627]Firmware upgrading[2]...
[00212677][03 06] Firmware upgrade start...
[00591058][03 06] Firmware upgrade finished successfully.
[00591163]Done.
[00591262]Version checking[3]...
[00591425][04 00][00] v1.51.0.0 -> v1.51.0.0
[00591646][11 00][00] v1.8.0.0 -> v1.8.0.0
[00591868][11 01][00] v1.8.0.0 -> v2.0.0.33, firmware v1.8.0.0 not support.
[00592110][11 01][00] v1.8.0.0 -> v2.0.0.33
[00592413][03 05][00] v34.2.0.9 -> v34.2.0.9
[00592606][03 06][05] v2.4.20.50 -> v2.4.20.50
[00605256][07 00][00] device not detected.
[00605430][09 00][05] v0.1.1.1 -> v0.1.1.1
[00605640][12 00][00] v5.9.0.0 -> v5.9.0.0
[00605852][12 01][00] v5.9.0.0 -> v5.9.0.0
[00606067][12 02][00] v5.9.0.0 -> v5.9.0.0
[00606268][12 03][00] v5.9.0.0 -> v5.9.0.0
[00606519][29 00][00] v2.4.1.231 -> v2.4.1.231
[00606671][29 01][00] v2.4.1.231 -> v2.4.1.231
[00606769]Packet upgrade failed at last version checking, Ret = -1.

The result:

[00006102]
========== 2014.01.01 00:00:06 remo-con disconnect======
[00006295]Packet: P3C_FW_V01.07.0800.bin [00006396]
[00029892]Upgrading ...
[00012108]
========== 2014.01.01 00:00:12 remo-con disconnect======
[00012223]Packet: P3C_FW_V01.09.0200.bin [00012328]
[00140534]Upgrading ...
[00606871]Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.
 
Last edited:
Joined
Oct 20, 2017
Messages
17
Reaction score
0
Age
27
I don't know what "[00606769]Packet upgrade failed at last version checking, Ret = -1." means, But have you tried reinstalling the firmware?
This happened when I tried reinstalling:

[00012651]========== Upgrade: remo-con disconnect. boot(1FF7)============
[00012755]Packet [C:\P3C_FW_V01.07.0800.bin] detected, card sn [0xda6ad315].
[00012856]Packet upgrade start...
[00012963]Packet checking...
[00013067]Packet vlink 01.07.0800 <-> 01.07.0090.
[00013164]Record vlink 01.07.0800 <-> 01.07.0090 (flow = 0).
[00013264]Done.
[00013361]Version checking[1]...
[00013516][04 00][00] v1.51.0.0 -> v1.51.0.0
[00026165][11 00][00] device not detected.
[00038816][11 01][00] device not detected.
[00051563][03 05][00] device not detected.
[00064211][03 06][00] device not detected.
[00076859][07 00][00] device not detected.
[00077021][09 00][00] v0.0.0.0 -> v0.1.1.0 need upgrade.
[00089670][12 00][00] device not detected.
[00102317][12 01][00] device not detected.
[00114970][12 02][00] device not detected.
[00127620][12 03][00] device not detected.
[00127869][29 00][00] v2.4.1.231 -> v2.4.1.231
[00128019][29 01][00] v2.4.1.231 -> v2.4.1.231
[00128119]Done.
[00130220]Waiting for user confirm...
[00140322]Timeout, start upgrade automatically.
[00140523]Firmware upgrading[1]...
[00141631][09 00] Firmware upgrade start...
[00165812][09 00] Firmware upgrade finish without reboot.
[00195914][09 00] Firmware upgrade finished successfully.
[00196021]Done.
[00196124]Version checking[2]...
[00196282][04 00][00] v1.51.0.0 -> v1.51.0.0
[00196528][11 00][00] v1.8.0.0 -> v1.8.0.0
[00196754][11 01][00] v1.8.0.0 -> v2.0.0.33, firmware v1.8.0.0 not support.
[00196854][11 01][00] v1.8.0.0 -> v2.0.0.33
[00197134][03 05][00] v34.2.0.9 -> v34.2.0.9
[00197334][03 06][00] v2.4.20.50 -> v2.4.20.28
[00209986][07 00][00] device not detected.
[00210198][09 00][05] v0.1.1.0 -> v0.1.1.0
[00210429][12 00][00] v5.9.0.0 -> v5.9.0.0
[00210645][12 01][00] v5.9.0.0 -> v5.9.0.0
[00210853][12 02][00] v5.9.0.0 -> v5.9.0.0
[00211067][12 03][00] v5.9.0.0 -> v5.9.0.0
[00211321][29 00][00] v2.4.1.231 -> v2.4.1.231
[00211476][29 01][00] v2.4.1.231 -> v2.4.1.231
[00211577]Packet upgrade failed at version checking.
 
Joined
Feb 25, 2017
Messages
4
Reaction score
0
Age
48
I have download the new up date for my p4 now won't let fly 30 mt from me and 30 mts high is there a way of getting the DJ settings
 
Joined
Feb 25, 2017
Messages
4
Reaction score
0
Age
48
I meant to say the older DJ settings and download if back so I be able to fly it away and high

Mick
 
Phantom Drones from EALLRC.com

New Threads

Forum statistics

Threads
136,718
Messages
1,413,750
Members
99,383
Latest member
vocc77