Drone broke in storage

Joined
Jan 8, 2021
Messages
9
Reaction score
5
Age
21
Hi I have searched but couldn't find anything relevant (also I'm new here),

So I had my Phantom 3 standard in the cupboard for maybe a year without flying. I went to fly it yesterday said it needed IMU calibration so tried to do that and it didn't work it kept failing at 2%.

I saw you can fix this issue by opening the drone up and tapping the IMU. So I did this and indeed it fixed the problem then went to fly the drone again everything seemed fine but as I went to take off the drone just flipped over. This was very concerning as I had never crashed the drone before.

As I picked the drone up and then armed the motors to give it ago again I noticed that in fact the rear motors were spinning significantly slower than the front and the rear left considerably slower.

Anyone got any idea what the problem could be I have never had any problems with the drone before never crashed or been near any water or rain with it. Seems like an esc problem but there are no burn marks or any visible damage.

Also can confirm when I opened the drone nothing was damaged in the process, I have take apart many drones and small electronics in the past and was careful not to touch the board when doing this procedure.

Any help would be much appreciated
 
  • Like
Reactions: ianzone

ianzone

**P4**
Joined
May 22, 2016
Messages
7,200
Reaction score
4,867
Age
51
Location
NZ
I have old p3s with slow motor on start up but gets up to speed ok to still fly normal,,,,,dumb question,,,,are your props going correct direction for the motors,is this manual or auto take off ?..and welcome,,,,with all props off will it rev even,,also since that amount of time pass give it a stick calibration
 
Last edited:
Joined
Jan 8, 2021
Messages
9
Reaction score
5
Age
21
yeh props are on the right motors and was a manual take off.

and when the props are off it seems fine,, but under load the rear isn't spinning right and i'll give stick calibration a go.

I have also tried to take off whilst holding it to see if it would pull up straight but it doesn't it always feels like it wants to flip backwards and toward the slow motor
 
  • Like
Reactions: ianzone

KachemakDiver

Premium Pilot
Joined
May 15, 2019
Messages
1,157
Reaction score
791
Age
59
Location
Homer,Alaska
Hi I have searched but couldn't find anything relevant (also I'm new here),

So I had my Phantom 3 standard in the cupboard for maybe a year without flying. I went to fly it yesterday said it needed IMU calibration so tried to do that and it didn't work it kept failing at 2%.

I saw you can fix this issue by opening the drone up and tapping the IMU. So I did this and indeed it fixed the problem then went to fly the drone again everything seemed fine but as I went to take off the drone just flipped over. This was very concerning as I had never crashed the drone before.

As I picked the drone up and then armed the motors to give it ago again I noticed that in fact the rear motors were spinning significantly slower than the front and the rear left considerably slower.

Anyone got any idea what the problem could be I have never had any problems with the drone before never crashed or been near any water or rain with it. Seems like an esc problem but there are no burn marks or any visible damage.

Also can confirm when I opened the drone nothing was damaged in the process, I have take apart many drones and small electronics in the past and was careful not to touch the board when doing this procedure.

Any help would be much appreciated
Was the drone sitting level when the IMU was successfully calibrated? Maybe show us a screen shot of the final results of the calibration. It may still have an accelerometer issue.
 

KachemakDiver

Premium Pilot
Joined
May 15, 2019
Messages
1,157
Reaction score
791
Age
59
Location
Homer,Alaska
Also, check the props for any damage now after the flip over. Maybe a prop hub slipping? Just tossing it out there.
 
Joined
Jan 8, 2021
Messages
9
Reaction score
5
Age
21
yeh was all level when calibrated and nope props are all in good shape. will post the readings now and a video of what's happening too
 
Joined
Jan 8, 2021
Messages
9
Reaction score
5
Age
21
cant seem to post videos is this even possible? here is a screen shot you can see the rear is hardly moving and a lot slower than the others i can give it a push and it will spin faster but not fast enough for flight
 

Attachments

  • IMG_6819.PNG
    IMG_6819.PNG
    2.6 MB · Views: 103
  • Screenshot 2021-01-09 at 11.45.55.png
    Screenshot 2021-01-09 at 11.45.55.png
    1.2 MB · Views: 84
Joined
Jan 8, 2021
Messages
9
Reaction score
5
Age
21
nope no errors in the app.

Could it be a bad motor? I thought that when brushless motors burnt out they completely stop.
 
Joined
Jan 8, 2021
Messages
9
Reaction score
5
Age
21
Very well could be. When you tapped on the stuck IMU,did you remove it from its black box or tapped on it installed?
removed it from the box, I wasn't sure about doing this but it hadn't worked from just tapping the outside and the guy on yt took it apart too so I did too
 

KachemakDiver

Premium Pilot
Joined
May 15, 2019
Messages
1,157
Reaction score
791
Age
59
Location
Homer,Alaska
removed it from the box, I wasn't sure about doing this but it hadn't worked from just tapping the outside and the guy on yt took it apart too so I did too
Ok, that’s what I recommend also. Verify that the IMU is completely snapped back into the box and it’s plugged in completely.
 

KachemakDiver

Premium Pilot
Joined
May 15, 2019
Messages
1,157
Reaction score
791
Age
59
Location
Homer,Alaska
cant seem to post videos is this even possible? here is a screen shot you can see the rear is hardly moving and a lot slower than the others i can give it a push and it will spin faster but not fast enough for flight
I noticed that the drone has prop guard mounts installed. Is there a possibility that they were removed at some point in time and those longer screws were going to be used without the guard mounts? You might inspect that motor to see if the motor windings have any damage.
 
  • Like
Reactions: ianzone

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,503
Reaction score
2,112
Age
69
Location
IRB, Fl
I noticed that the drone has prop guard mounts installed. Is there a possibility that they were removed at some point in time and those longer screws were going to be used without the guard mounts? You might inspect that motor to see if the motor windings have any damage.
Those screws have killed a lot of motors. At least the motor replacement is an easy, inexpensive fix for someone that's been inside already.
 
Joined
Jan 8, 2021
Messages
9
Reaction score
5
Age
21
I did buy the drone used so not sure about the history but since I have been using it it has worked fine and I have never taken the bolts out until I did the imu and when I replaced them I kept the prop guards in place so don't think thats the problem.

Although when I unbolted the motors I did notice they were screwed in pretty **** tight and the plastic was slightly cracked, so when I put them back in I didnt torque them as much as they were.

I guess we will know the answer when I get the new motor
 
Joined
Jan 8, 2021
Messages
9
Reaction score
5
Age
21
Turns out it was a bad motor. when I mounted the motors I must have screwed the bolt in too far. Which is odd because when I took them off I noticed they were very very tight so when I replaced them I was very very gentle yet I still damaged the motor.

I feel like this is a major defect with this part/drone that this breaks them so easily! I'm going to try and find some short bolts and remove the prop guards I never used them anyway!
 
  • Like
Reactions: ianzone

ianzone

**P4**
Joined
May 22, 2016
Messages
7,200
Reaction score
4,867
Age
51
Location
NZ
Turns out it was a bad motor. when I mounted the motors I must have screwed the bolt in too far. Which is odd because when I took them off I noticed they were very very tight so when I replaced them I was very very gentle yet I still damaged the motor.

I feel like this is a major defect with this part/drone that this breaks them so easily! I'm going to try and find some short bolts and remove the prop guards I never used them anyway!
Ok you can get these,this just 1 sort but there many to choose from,,these mount under the motor to prevent further cracking and works as a brace,,very cheap too,,yeh,,gota watch those screws,,,these sets come with correct size screws,,,couple pics so you know how these work
Screenshot_20210113-104305_Google.jpg
mqdefault.jpg
Screenshot_20210113-102602_Chrome.jpg
 
Last edited:

New Threads

Members online

Forum statistics

Threads
141,097
Messages
1,453,240
Members
102,926
Latest member
jimfronk