DJI App Disconnecting

Joined
Jul 13, 2014
Messages
139
Reaction score
7
HI guys,

Can anyone explain why the app keeps disconnecting on me? I've tried deleting and reinstalling it....

 
Joined
Apr 6, 2015
Messages
276
Reaction score
82
I have the same issue, with my Lenovo 7" but does works fine with the 10". I too would like some feedback on this issue. I will be sending the flight data to DJI later today. So lets see. I cant see exactly what tab you are using? Android? or Apple?

For all interested my 7 in is:

Lenovo A550H
Android 4.4.2
Chipset Mediatek MT8382
CPU Quad-core 1.3 GHz Cortex-A7
GPU Mali-400MP2
 
Last edited:
Joined
Jul 13, 2014
Messages
139
Reaction score
7
I have the same issue, with my Lenovo 7" but does works fine with the 10". I too would like some feedback on this issue. I will be sending the flight data to DJI later today. So lets see. I cant see exactly what tab you are using? Android? or Apple?

For all interested my 7 in is:

Lenovo A550H
Android 4.4.2
Chipset Mediatek MT8382
CPU Quad-core 1.3 GHz Cortex-A7
GPU Mali-400MP2
its an ipad mini 2
 
Joined
Apr 6, 2015
Messages
276
Reaction score
82
as in the above link, I switched off the wifi, and switched off the wifi in advanced settings and the 7" works fine now. 20 minute flight without an issue.
 
Joined
Mar 20, 2014
Messages
331
Reaction score
3
Location
Cape Cod, Ma.
Just a thought but does it do this while in flight?
My thought was that because you have the transmitter antenna so close to the P3 that it might be overloading it with rf.
 
Joined
Apr 6, 2015
Messages
276
Reaction score
82
yes it did it in mid flight. It is without a doubt a wifi issue for me. As soon as I switched wifi off. It seems to have solved the prob. That said, another couple of flights is required to determine if it is solved
 
Joined
Jul 13, 2014
Messages
139
Reaction score
7
Hi guys,

So tonight i flew it again with a different cable. Same thing happened, still have control of the phantom 3 pro but still getting disconnected. Its definitely not the cable.

It also can't be wifi as im using an ipad mini 2 without any 3g/4g/wifi at the moment (it is a cellular but i have no working sim card in there).

So any ideas?!
 
Joined
Apr 6, 2015
Messages
276
Reaction score
82
Hi guys,

So tonight i flew it again with a different cable. Same thing happened, still have control of the phantom 3 pro but still getting disconnected. Its definitely not the cable.

It also can't be wifi as im using an ipad mini 2 without any 3g/4g/wifi at the moment (it is a cellular but i have no working sim card in there).

So any ideas?!
I found this link... might be of interest to you:

http://forum.dji.com/forum.php?mod=viewthread&tid=14644
 
Joined
May 12, 2015
Messages
278
Reaction score
163
Age
43
Location
Los Angeles, CA
This is more than a little concerning as I'm literally updating as we speak.

o_O
 
Joined
Feb 3, 2015
Messages
3,858
Reaction score
1,149
Location
Long Island, NY
I've not experienced this issue after the firmware update. On a Shield, so it's likely device specific.
 
Joined
Jul 13, 2014
Messages
139
Reaction score
7
Looks like there are lots of people with this issue. I never flew with the 1.1.6 so couldnt tell you - ive only ever had the 1.1.8....
 
Joined
Apr 6, 2015
Messages
276
Reaction score
82
I found that it also kept disconnecting when I had removed the log file, as soon as I replaced it from a previous version it worked again
 
Joined
Apr 16, 2015
Messages
198
Reaction score
97
Location
Cincinnati, OH
I'm also having this issue. It's not the cable and disabling wifi only helps a little. The only thing that gets it to stop for me is to land and reboot the controller before taking off again. Frustrating.
 
Joined
May 18, 2015
Messages
8
Reaction score
2
Age
42
I am on 1.1.8 with an iPad Mini 2 wifi and have never had this problem. Not a lot of help but it sounds like the same setup as you.
 
Joined
Apr 6, 2015
Messages
276
Reaction score
82
Does it fly fine without the SD card in?

Some devices disconnect when you start video or take a photo.
 
Joined
Apr 16, 2015
Messages
198
Reaction score
97
Location
Cincinnati, OH
There are several threads about this both here and on the DJI forum. I don't think it has to do with the cables or the SD card. I'd have to agree with the people who theorize that this is a signal issue. For me, turning wifi off on my tablet helps a LITTLE (lowers the probability, does not eliminate the issue). Flying in an area with a lower density of wifi routers helps (if I fly around my neighborhood, with a lot of houses close together it is 100% guaranteed to disconnect). The only thing that resolves this for me, at least temporarily, is to land and reboot the controller. Also, I NEVER got this issue with the old firmware and the old Android app.

If this was indeed changed because of a restriction of channels in the last firmware update, I hope it is something DJI can work through in a future update. This cripples Lightbridge and really makes me scared to fly with FPV instead of strictly LOS. Once the disconnection issues start I am at the mercy of RTH and then LOS for my landing.
 
Joined
Feb 3, 2015
Messages
3,858
Reaction score
1,149
Location
Long Island, NY
I read on rcgroups one guy said if he removes his tablet from the mount (ie, away from the controller), he no longer lost connection. maybe give that a try and confirm back.