Joined
Aug 3, 2016
Messages
3
Reaction score
0
Age
29
Hello my fellow Phantom pilots!! I am probably not the only pilot suffering this "disconnect" nightmare at this current moment. I have the Phantom 4 and when I received it I followed the usual procedure of activating, calibrating and all the good stuff. I had a successful flight and flew 6 times already(pretty impressive machine).

I already have upgraded to the latest firmware and it still didnt work. I then downgraded but it still shows as disconnect. I can arm the rotors and move camera but cannot see the camera.

Dam!! I just got to Peru and wanted to film all of the Andes and this **** happens! I talked to customer support but no luck. all they say is to try a diffrent devce. FML PLs HELP?
 
Joined
Jul 7, 2015
Messages
66
Reaction score
18
Age
56
Sorry you are having this problem. Have you tried to delete the DJI GO app and then do a reinstall of it? That may work. It's worked for me in the past.
 
Joined
Jun 1, 2014
Messages
36
Reaction score
9
Try a new usb cable, got problems with disconnect due to that.
/Hakan
 
Joined
Aug 3, 2016
Messages
3
Reaction score
0
Age
29
Sorry you are having this problem. Have you tried to delete the DJI GO app and then do a reinstall of it? That may work. It's worked for me in the past.

I have reinstalled and installed several times and including reformatted my phone to original state. No luck.
 
Joined
Apr 4, 2016
Messages
442
Reaction score
181
Age
59
Location
Woodlands, MB Canada
I take it, that it's only the video that's 'Disconnected'. In this case, simply removing and replacing the MicroSD card sometimes works.

I had that problem just last week. I went through resetting, rebooting and pulling my hair out. As soon as I popped out the MicroSD card, the video disconnected error went away and I had live video on my screen again.
 
Last edited:

New Threads

Forum statistics

Threads
138,529
Messages
1,430,439
Members
100,541
Latest member
six2twelve