Crash help

Joined
Apr 10, 2015
Messages
8
Reaction score
0
Age
48
Hi there, first post. Sorry but I looked and couldn't fund info on this one. Crashed: bent gimble brackets and one of the gimble arms seems bent. I disconnected it and took it off for now.
All lights working but motors don't run at all. I found a tiny screw lodged in one motor but retrieved it. It's as if the copter isn't receiving communications from controller. Where do I look next?
 
Joined
Oct 22, 2014
Messages
940
Reaction score
38
Location
NYC
1. What are the LEDs showing?
2. Plug it in to a computer, run the Phantom Assistant sofware, check the controls, see what units show up in firmware listing.
 
  • Like
Reactions: Antiguan
Joined
Apr 10, 2015
Messages
8
Reaction score
0
Age
48
hey, thanks for the reply. all the lights seem to flash when i power up and then quite quickly the yellow ones flash on and off. i tried to download the phantom assistant software, but my mac OS seems to be too old. sucks!
 
Joined
Oct 12, 2014
Messages
5,163
Reaction score
576
Location
Commerce Twp,MI
There is a possibility that the GPS connector may have come loose but the only way to find out you'd have to open up the shell. Since have crashed your unit you will have to re-calibrate the IMU use the P2 assistant software. That means you will need to use your computer. If your Mac isn't up to the task how about a friend with a PC.
 
  • Like
Reactions: Antiguan
Joined
Oct 12, 2014
Messages
5,163
Reaction score
576
Location
Commerce Twp,MI
If you have to take it to a friend he will have to download all the software and driver. I suggest you don't download v3.8 but instead download v3.6 instead as you can always upgrade later. Hopefully you don't already have the latest installed on your unit.
 
  • Like
Reactions: Antiguan
Joined
Apr 10, 2015
Messages
8
Reaction score
0
Age
48
downloaded software, did calibration and she's flashing red, green and yellow. No noticeable communication with remote
 
Joined
Oct 12, 2014
Messages
5,163
Reaction score
576
Location
Commerce Twp,MI
downloaded software, did calibration and she's flashing red, green and yellow. No noticeable communication with remote
Do you have access to both the RC and P2 assistant software and also the v1.2 user manual? Did you open the shell to check if the GPS was plugged in?
 
Last edited:
Joined
Apr 10, 2015
Messages
8
Reaction score
0
Age
48
Didn't download the v1.2 manual and after not getting anywhere earlier, I did the firmware update. Got the new assistant too.
 
Joined
Oct 12, 2014
Messages
5,163
Reaction score
576
Location
Commerce Twp,MI
Didn't download the v1.2 manual and after not getting anywhere earlier, I did the firmware update. Got the new assistant too.
Since you updated your firmware do a complete calibration of both the RC and P2 including the advanced IMU calibration on a level surface. Did you open the shell to make sure the GPS was plugged in. If it isn't the motors will not turn on. Also use this link to download the v1.4 users manual:
http://www.dji.com/product/phantom-2/download

Once you've completed all the software calibrations take it outdoors and do a compass calibration then tell me what it does or doesn't do.
 
Last edited:
Joined
Apr 10, 2015
Messages
8
Reaction score
0
Age
48
The GPS was unplugged originally, but I got it back in. Still no joy though after calibration. Going outside now.
 
Joined
Oct 12, 2014
Messages
5,163
Reaction score
576
Location
Commerce Twp,MI
The GPS was unplugged originally, but I got it back in. Still no joy though after calibration. Going outside now.
Are you sure you completed calibrating both the RC and P2? It takes close to 20 minutes to do both.
 
Joined
Apr 10, 2015
Messages
8
Reaction score
0
Age
48
Went outside and get same red, green, yellow. Each time I try the assistant it tells me I need to do an advanced calibration to calibrate the imu. Most times I'm calibrating it tells me the mc is too hot.
 
Joined
Oct 12, 2014
Messages
5,163
Reaction score
576
Location
Commerce Twp,MI
Went outside and get same red, green, yellow. Each time I try the assistant it tells me I need to do an advanced calibration to calibrate the imu. Most times I'm calibrating it tells me the mc is too hot.
When that message comes up key over the red X in the upper right corner as that is an error message and the advance calibration will continue. Once it is completed do compass cal. And please download that manual and read it
 

New Threads

Forum statistics

Threads
139,312
Messages
1,437,368
Members
101,179
Latest member
UAmetry