Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

"Connection Broken" issues....WHAT???

Discussion in 'DJI Lightbridge' started by isky172, Nov 13, 2014.

  1. isky172

    Jul 9, 2014
    Likes Received:
    Booted up the rig this evening to prepare for some flying tomorrow (i.e., camera settings, battery levels check, etc....). The last time I touched the P2 (non-Vision) w/Lightbridge was a few weeks ago during firmware updates for everything - LB ground/air, etc.. The firmware as of this writing is 1.4.7 and whatever else (decoder/transmitter) versions accompanied LB Assistant 1.3. I don't think I flew it after those updates (updates which also included P2 batteries and for the P2 itself).

    I'm now getting "Connection Broken" issues on all the monitoring devices I connect to the LB ground box. It's not an app issue - two devices are running different versions of the LB app (Android). For what it's worth, one is a Galaxy Note 2 and the other is a Galaxy Note Pro 12.2. Both of them are getting this connection-on / connection-broken problem. Used two different USB wires to ensure they weren't the problem.

    The reason I say it's not the app is because when the app is closed and purged from memory, the top of the screen has an indicator that intermittently says "Connected as a Media Device" every few seconds....which tells me the LB Ground station is disconnecting and reconnecting over and over again. When I open the app and look at its behavior the Android OS "Connected as a Media Device" translates to a circular "I'm doing some processing" icon in the middle of the app. It will eventually turn into a prompt asking you if you want to "exit" or "wait".

    On the air end of the LB setup, all lights are green.

    So I'm thinking this is a firmware issue caused by their recent "update". It's that or my LB ground device was mysteriously hacked by gremlins sneaking around at night. I don't think it's busted (outside of the firmware being screwed up) because during the few seconds (2 or 3 secs) between the flipping on to off I DO GET A PICTURE on my screen of what the P2 is pointed at. The P2 seems otherwise controllable but I dare not bring it up in the air.

    I also have to note that the ground unit seems quite a bit warmer than I remember it being for any amount of "on" time. In fact, I'd say it's kinda hot (after 10 mins of being "on").

    Anyone else getting this "Connection Broken" error occurs every few seconds? If so, close the app and look at the top of your device's screen. Do you get the "Connected as a Media Device" msg every 5 to 10 secs or so (estimate)?


    I went to DJI's page and downloaded the 1.2 version of the Lightbridge Assistant. Installed it. Plugged in my Ground unit and "upgraded" to the previous versions of the ground-based firmwares (Main 1.1.9, Decoder 1.4.5). I'm happy to say there is no "Connection Broken" or any other errors I mentioned above. So yeah...the latest firmware (the LB Assistant 1.3 packages) trashes the Ground part of the LB. At least it does on my setup....and I can't imagine how it would be any different for other Android based LB flyers (and perhaps iOS folks too).

    Anyway - hope this helps if anyone has the same experience. Solution = download LB Assistant 1.2 (quick, while it's still available) and "upgrade" your firmware for Ground system elements back down (i.e., for each of the 3 ground elements, click on the words "No Update" in the far right column after it posts the firmware values of what it finds there currently. I started with the Decoder...which took the longest, then updated the Main, and finally updated the Transmitter element). I left all the Air side firmware as-is (whatever is most current from DJI as of Nov 14, 2014 for LB Assistant 1.3) for now...no video or control problems as of this moment (10+ mins into live testing).
  2. madeinengland

    Apr 8, 2014
    Likes Received:
    Marlborough uk
    No such message my end when using the latest updates.Using ipad 2 mini as display with ios 8.1.
    I will keep a careful watch on the system that's for sure but at the moment I could not be happier withe the setup.
  3. Skunky

    Aug 23, 2014
    Likes Received:
    I use an android. My upgrade and LB work perfectly fine.
  4. Jimbob HiVu

    May 25, 2014
    Likes Received:
    I had same "connection broken" issue after I did the last firmware update. Tried all sorts to fix it. Checked all cable connections and still nothing with red video light still on on Airstation.

    I then just pulled out the HDMI plug out of the Airstation and pushed it back in and hey presto I got the video feed back.

    No idea why this worked as I had checked several times that the HDMI plugs were firmly in place both at camera and Airstation ends.

    Hope this might be of use to others experiencing similar problems.
Similar Threads - Connection Broken issues Forum Date
Broken USB connection to RC? Phantom 4 Help Aug 22, 2016
Professional Go app states in battery status connection broken Phantom 3 Help Nov 17, 2015
Phantom Connection Broken Phantom 2 Vision + Help Oct 19, 2015
phantom connection broken Phantom 2 Vision + Help Sep 23, 2015
phantom connection broken General Discussion Jun 7, 2015