Compass Calibration fail

Joined
Apr 10, 2015
Messages
15
Reaction score
4
Age
62
Hi all,

I have a new P3 and had a great first flight. I've read the manual, watched the tutorials etc. I've been flying RC heli's for many years. Had an odd thing happen, I went out, the next day, and tried to do a compass calibration (probably not required) and it failed. Now I cannot get my bird to calibrate at all. I've tried all around the property (I live in a rural are not really susceptible to EMI), I drove about 5 miles to an abandoned orchard and still no luck. When I calibrate horizontally I get a solid green LED, when I do the vertical it goes to flashing red.... I'm pretty frustrated.

Any creative ideas?

Running the latest FW 1.19.

thanks,
Lesn8r
 
Joined
Jun 25, 2014
Messages
1,018
Reaction score
504
Age
70
Location
Pomona, IL
Counterclockwise??
 
Joined
Jun 25, 2014
Messages
1,018
Reaction score
504
Age
70
Location
Pomona, IL
Have you done an IMU calibration since the failure?
 
Joined
Feb 13, 2015
Messages
1,071
Reaction score
213
Location
SoCal, USA
I'm not sure if it that's the issue but are you going too slowly?
 
Joined
Apr 10, 2015
Messages
15
Reaction score
4
Age
62
I'm not sure if it that's the issue but are you going too slowly?
Hmmm, I don't know. I did slow down when things started failing. Perhaps I'll try speeding it up. Hopefully the rain stays away tomorrow!
 
Last edited:
Joined
May 4, 2014
Messages
36
Reaction score
4
Location
South West Scotland
Hi all,

I have a new P3 and had a great first flight. I've read the manual, watched the tutorials etc. I've been flying RC heli's for many years. Had an odd thing happen, I went out, the next day, and tried to do a compass calibration (probably not required) and it failed. Now I cannot get my bird to calibrate at all. I've tried all around the property (I live in a rural are not really susceptible to EMI), I drove about 5 miles to an abandoned orchard and still no luck. When I calibrate horizontally I get a solid green LED, when I do the vertical it goes to flashing red.... I'm pretty frustrated.

Any creative ideas?

Running the latest FW 1.19.

thanks,
Lesn8r
Just had same problem but thanks to some on forum it's sorted. When you do your 360 keep going a bit further than normal on both horizontal and vertical I was at 360 plus around 90 and successful first time. Hope this helped you to.
 
  • Like
Reactions: snowghost
Joined
Feb 13, 2015
Messages
1,071
Reaction score
213
Location
SoCal, USA
Just had same problem but thanks to some on forum it's sorted. When you do your 360 keep going a bit further than normal on both horizontal and vertical I was at 360 plus around 90 and successful first time. Hope this helped you to.
Wow, that is good to know.
 
  • Like
Reactions: Ghanz
Joined
Feb 13, 2015
Messages
1,071
Reaction score
213
Location
SoCal, USA
Not had an issue since the post in May.
 
Joined
Feb 1, 2014
Messages
4,308
Reaction score
936
Location
Indy, USA
Did you fix the compass problem.I am having the same issue
Check youtube for a tutorial, or the app's library may have it as well. Several of us calibrate the aircrafts compass prior to each flight and or battery change.
 

O.P

Joined
Dec 11, 2015
Messages
7
Reaction score
0
Age
48
I know how the calibration is performed, but it fails when I do it. This all started after a "critical" landing. I was able to recover aircraft with no damage, other than a rubber damper came off gimbal. I have done imu calibration and still nothing.
 
Joined
Apr 10, 2015
Messages
15
Reaction score
4
Age
62
For those who have asked; I had to return the unit. I worked with the vendor and they replaced my bird. I've had no issues with the new bird.
 

New Threads

Forum statistics

Threads
135,466
Messages
1,401,592
Members
98,667
Latest member
Zelk12