Can't connect to Samsung s6 or Samsung Tablet

Joined
Oct 3, 2016
Messages
6
Reaction score
0
Age
65
I have a P3P and a Samsung S6 and Samsung Tablet and finding connecting to either is almost impossible!

I run Litchi and have deleted Dji Go

I power on the RC then the P3P and then connect the phone or tablet. Sometimes it will connect first time, other times only after I select usb mode to Rndis and sometime not even then.

I have a 2 brand new samsung usb cable that I use.

Even if it does not connect, I can still control the aircraft ( ie, start stop motors or move the camera)

If it does connect, the video feed stops after a min or two and I can not "see" what the camera is looking at. There is no indication on the screen that I have lost connection, just that the video remains frozen. I have to bring it back, land, and try to reconnect.

As far as I know I have the latest firmware on the phone, the app and the P3P.

Can anyone help? Why am I loosing the video feed?

Thanks
John
 
Joined
Aug 15, 2016
Messages
3,587
Reaction score
1,533
Age
39
Do you still get the info like height, battery, sats, etc... if so it could be a ribbon cable problem to the camera. Have you checked that's it's not damaged or disconnected
 
Joined
Aug 4, 2017
Messages
232
Reaction score
69
Location
Derbyshire
Are you in developer mode in both devices ?
if you search we have a "What Tablet" thread, loads of information about these issues in there.
 
Joined
Jul 26, 2017
Messages
1,981
Reaction score
988
Location
Irvine (Orange County) CA
I have a P3P and a Samsung S6 and Samsung Tablet and finding connecting to either is almost impossible!

I run Litchi and have deleted Dji Go

I power on the RC then the P3P and then connect the phone or tablet. Sometimes it will connect first time, other times only after I select usb mode to Rndis and sometime not even then.

I have a 2 brand new samsung usb cable that I use.

Even if it does not connect, I can still control the aircraft ( ie, start stop motors or move the camera)

If it does connect, the video feed stops after a min or two and I can not "see" what the camera is looking at. There is no indication on the screen that I have lost connection, just that the video remains frozen. I have to bring it back, land, and try to reconnect.

As far as I know I have the latest firmware on the phone, the app and the P3P.

Can anyone help? Why am I loosing the video feed?

Thanks
John
I would re-install and test it using GO if only to eliminate any hardware issues. I recall reading something about Litchi and Samsung requiring some special work-arounds.
 
Joined
Oct 3, 2016
Messages
6
Reaction score
0
Age
65
Do you still get the info like height, battery, sats, etc... if so it could be a ribbon cable problem to the camera. Have you checked that's it's not damaged or disconnected
No, I can still fly the drone but everything is visual. No info on the phone as it all freezes
 
Joined
Oct 3, 2016
Messages
6
Reaction score
0
Age
65
Are you in developer mode in both devices ?
if you search we have a "What Tablet" thread, loads of information about these issues in there.
Yes, Am in developer mode. Although if I select RNDIS as the usb connection it often defaults back to MTP
 

ianzone

LONEWOLVE
Premium Pilot
Joined
May 22, 2016
Messages
5,192
Reaction score
2,734
Age
49
Location
EARTH.NZ
Yes, Am in developer mode. Although if I select RNDIS as the usb connection it often defaults back to MTP
Was just reading and I remember on my p4 just recent,,this tab A device and when I first had set up issue mine would not conect to app until late I had set it on T I,,this when MTP not avaliable, now after reading your post to get ideas I notice mine set on ""none"",,,as yours does mine also returns to this setting when trying to select,I remember I could change it before,,my developer option is off,,,does the camera get over hot when on for that short period,,,is this drone new,,,have you tryed a decent sd card in it,,can't not say it device cause I use Samsung aswell and have worked good ,this going to bug me all night now so I be thinking
Screenshot_20180914-203954.jpg
 

New Threads

Forum statistics

Threads
134,933
Messages
1,395,948
Members
98,327
Latest member
DJIPhantom3SE_danish