Standard 1st time newby, tablet registration help

Joined
Jan 24, 2018
Messages
6
Reaction score
2
Age
42
I just downloaded the app from dji (not playstore) and the first thing that shows up is a page telling me to enter a registered email, then a ''i'm not a robot 4 letter test'' ... I enter those and hit done, and it takes me to a 'enter a password' line, so i type in a password, but there's no ''enter'' button, and hitting the ''done'' button does nothing.. it just stays there on the 'enter password' page.... what the hell am i doing wrong here? Do i have to register somewhere else first?
 
Joined
Sep 30, 2017
Messages
1,528
Reaction score
1,313
Location
Kansas
I had a very similar problem like that last week......i even asked what was going on on this site because the button never showed UP for me to log in to the Dji site.....i got no answers however it worked two hours later....It was a Dji server problem....i finally got a answer from a Dji administrator and asked if it had finally worked and i answered back yes it did ...Gee keep trying and hope it will finally work.
 
  • Like
Reactions: Doctor Tank
Joined
Jan 24, 2018
Messages
6
Reaction score
2
Age
42
I had a very similar problem like that last week......i even asked what was going on on this site because the button never showed UP for me to log in to the Dji site.....i got no answers however it worked two hours later....It was a Dji server problem....i finally got a answer from a Dji administrator and asked if it had finally worked and i answered back yes it did ...Gee keep trying and hope it will finally work.
Did you have to un-install the app, then install it again?
 
Joined
Sep 30, 2017
Messages
1,528
Reaction score
1,313
Location
Kansas
Noooooooooo i waited it out and retied it and it worked like it was supposed to.....It might be a great idea to uninstall the Go App and re install it....The Best of Luck to you and hey might be good to call Dji support IF you still have a problem.
 
Joined
Jan 24, 2018
Messages
6
Reaction score
2
Age
42
Noooooooooo i waited it out and retied it and it worked like it was supposed to.....It might be a great idea to uninstall the Go App and re install it....The Best of Luck to you and hey might be good to call Dji support IF you still have a problem.
Okay... thanks . . And from one motorcycle rider to another... stay safe out there. :)
 
  • Like
Reactions: MotorCycle-Man

New Threads

Forum statistics

Threads
136,170
Messages
1,408,406
Members
99,079
Latest member
aneal321