Wonky controller

Joined
Apr 25, 2016
Messages
6
Reaction score
0
Age
68
Location
Glenrothes, Fife (UK)
Hi. I have a P3 Advanced and until recently everything has been fine. However, recently the controller began beeping, which I understood to mean low power. A single white LEDwas showing. I put it on charge but after several hours there was no change. I did manage to borrow a battery which was known to be fine, and connected this to my controller. Same light and beeping, and again the controller would not charge.

The drone is fine, and the controller still speaks to it (I can start and stop the drone motors) but even with a known ok battery I could not do any charging. I'm of the opinion that the fault is with the controller itself, but I'd be interested to hear other views. I've already tried the Facebook pages, but didn't find enlightenment there :(
 
You been gone for awhile. :)

What it the time frame on recently?
Week, Month or Year?

"I did manage to borrow a battery which was known to be fine, and connected this to my controller."
This lost me doesn't the battery need to be in the controller?

Rod ..
 
The P4 had an issue where the controller wouldn’t hold a charge. It was a component on the main board. I eventually sent mine back to DJI and they repaired/sent me a new controller for $99. There was a fix called reflowing the solder on the component, heating it with a heat gun. I tried it a few times and it would last a bit but eventually revert.
 
  • Like
Reactions: RodPad
Thankfully these remotes are inexpensive nowdays. Some refloat the board with heat (see youtube) but if successful, it's short lived. Linking a replacement used or new remote is simple on these older models.
 

Members online

No members online now.

Forum statistics

Threads
143,153
Messages
1,468,001
Members
105,051
Latest member
stovesparesdirectuk