Standard weak signal, won't bind, flashing yellow.

Joined
Oct 29, 2016
Messages
3
Reaction score
0
Age
54
Hello,

I'm looking for some help with my new phantom 3 standard

I'm getting the weak signal message on my go app.

I'm getting solid red lights and fast yellow flashing on bird.

Bind light is red I've tried binding though the app and from the controller by pushing the switch by the red light till it flashes but never get green (Probably the root of my issue )

I have spent hours reading up on this and I have tried all of the suggestions...

Desperate and out of options..... :(



Bill
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,457
Reaction score
1,021
Age
56
Location
Pacific,NorthWet, 97031
Hello,

I'm looking for some help with my new phantom 3 standard

I'm getting the weak signal message on my go app.

I'm getting solid red lights and fast yellow flashing on bird.

Bind light is red I've tried binding though the app and from the controller by pushing the switch by the red light till it flashes but never get green (Probably the root of my issue )

I have spent hours reading up on this and I have tried all of the suggestions...

Desperate and out of options..... :(



Bill
Welcome to the Forum!
At least you haven' crashed it! :)

Yes, Red led that is a problem, not good.

Rod

Added: Took a look here on tips DJI Phantom Accessories & Tips - Phantom Help
I wish they would use the word no signal, instead of weak signal.
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,457
Reaction score
1,021
Age
56
Location
Pacific,NorthWet, 97031
@bill plemmons

The post above I had actually posted the wrong link, but changed it in about a minute, it would have taken you to the Phantom help again.

Found another on on linking with out the app,
Newbie first crash

Got any more info, what you tried or not, somebody else that has a Phantom.

Rod
 
Joined
Oct 29, 2016
Messages
3
Reaction score
0
Age
54
@bill plemmons

The post above I had actually posted the wrong link, but changed it in about a minute, it would have taken you to the Phantom help again.

Found another on on linking with out the app,
Newbie first crash

Got any more info, what you tried or not, somebody else that has a Phantom.

Rod

It must be hardware related...

I've done that several times..... :(

I think I will just part it out....( I have another drone. )

Thanks for the help though

Bill
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,457
Reaction score
1,021
Age
56
Location
Pacific,NorthWet, 97031
Great, but,
I couldn't figure out why you would part it out, if it was new?

Camera/Gimbal has the Mac address, so no signal output for the Phantom, so you couldn't bind?

What was the color on the remote? Red?

Rod
 

New Threads

Forum statistics

Threads
134,911
Messages
1,395,705
Members
98,309
Latest member
jim.gr