Weak Image Transmission Signal. Adjust Antenna

Joined
Aug 29, 2017
Messages
8
Reaction score
0
Age
70
Just recently started to get the 'above error message' Everything was fine a few weeks ago.
Tried the usual things,
Fully charged bats
Refreshed app
Recalibrated IMU/Compass
Diff cable ( which I thought it was initially)
Refeshed firmware using DJI Assist 2

The signal freezes, breaks up and the P4Pv2 disconnects, as per the message above, no stick response, it hovers, then reconnects and I'm able to bring it back. (Figure on left). I have discovered that if I select 5.8gHz channel I get a much better flight exeperience over the same area see below fig 2). If I revert to Dual or 2.4gHz, I get the above behaviour. Any ideas of a fix? Or what's causing the problem? I have a P4P back up (LightBridge), that doesn't exhibit this problem. I have a Mavic Pro 2, (occusync) again no problem. I use an iPad Mini 4 in all instances. I've not tried support yet (I've not had a good experience previously). So, any ideas please? It's driving me nuts and turning me into a nervous fly as I'm losing confidence in this expensive piece of kit.

Thanks

View attachment 119136 View attachment 119137
 

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,376
Reaction score
2,002
Age
69
Location
IRB, Fl
Cannot open attachments.
Bad forum day for v2. All with signal problems? Happy to stay with v1.
 
Joined
Aug 29, 2017
Messages
8
Reaction score
0
Age
70
What firmware is on your P4pv2 and on your controller?

Attached/Appended image from Go4app. Refreshed last Friday. I've checked the release version on my P4P and it this same. However, yesterday when I was trouble shoouting this, I noticed that the 'Dual' option had been de-selected and '5.8' selected instead which might explain why the P4P has seemed not to have suffered the same problem, although I cannot recall setting it 5.8 ???

P4Pv2 Versions.

1592994238856.png
 
Joined
Apr 17, 2017
Messages
4
Reaction score
0
Age
62
Here is whAt is probably going on. Either your 2.4 ghz antenna has come loose or your 2.4 ghz radio in the drone is blown.

I’m having the same issues with my P4pv2. It’s now on its way to DJI.
 
Joined
Aug 29, 2017
Messages
8
Reaction score
0
Age
70
Here is whAt is probably going on. Either your 2.4 ghz antenna has come loose or your 2.4 ghz radio in the drone is blown.

I’m having the same issues with my P4pv2. It’s now on its way to DJI.
Thanks JoeBFLL,

Did you talk to dji support to get them to accept it back for a fix?
Thanks
 
Joined
Aug 29, 2017
Messages
8
Reaction score
0
Age
70
Indeed. My v2 is just over 2 years old. It’s my favourite and go to drone. Just waiting for the shipping labels to arrive to be printed off.
 
Joined
Jun 25, 2020
Messages
116
Reaction score
86
Age
62
Location
Denton, TX
Just recently started to get the 'above error message' Everything was fine a few weeks ago.
Tried the usual things,
Fully charged bats
Refreshed app
Recalibrated IMU/Compass
Diff cable ( which I thought it was initially)
Refeshed firmware using DJI Assist 2

The signal freezes, breaks up and the P4Pv2 disconnects, as per the message above, no stick response, it hovers, then reconnects and I'm able to bring it back. (Figure on left). I have discovered that if I select 5.8gHz channel I get a much better flight exeperience over the same area see below fig 2). If I revert to Dual or 2.4gHz, I get the above behaviour. Any ideas of a fix? Or what's causing the problem? I have a P4P back up (LightBridge), that doesn't exhibit this problem. I have a Mavic Pro 2, (occusync) again no problem. I use an iPad Mini 4 in all instances. I've not tried support yet (I've not had a good experience previously). So, any ideas please? It's driving me nuts and turning me into a nervous fly as I'm losing confidence in this expensive piece of kit.

Thanks

View attachment 119136 View attachment 119137

The 5.8gHz channel has much higher bandwidth but it has less range. If you are flying close to the controller (within a 1000 yards) location you are usually better off using the 5.8gHz band for control. Aside from electronic issues that might be the cause, you could be getting some interference in the area you were flying. It rarely happens to me but there are some spots I fly that it is a matter of when rather than if it will happen.
 
Joined
Aug 29, 2017
Messages
8
Reaction score
0
Age
70
Well, I thought I'd bring you up to speed with my experience with getting a shipping label out of DJI Support. I'm disappointed to say the least. It's not the cost but the convenience of getting a label, sticking it on the package, knowing it will be safely despatched for repair and returned when complete. For those who may be interested in the email dialogue, I have attached a pdf of the thread and my 'bleatings' with DJI Support. Needless to say, I didn't score DJI to highly on the follow-up Cust Satis survey
 

Attachments

  • RE_ [DJI Support] _ RE RE_ CAS-4601400-J5N6B8.pdf
    212 KB · Views: 52

New Threads

Forum statistics

Threads
140,502
Messages
1,448,283
Members
102,294
Latest member
vfrf2