Video delayed from drone.

Joined
May 8, 2014
Messages
81
Reaction score
7
Age
72
Location
Indian Rocks Beach, FL
One more question. I usually fly Litchi software. Recently, I have noticed that my video feed is delayed. For example, if I make a controller input, such as yaw or climb, the video of the movement is delayed. This is very annoying and makes setting up a nice video shot nearly impossible. Well, I updated the drone and controller software yesterday. Everything flies great, but I still have the lagging video issue. Anyone else had this problem? I am ready to fly with the DJI software to see if the problem is with Litchi or if it is something in the video downlink as it would affect both platforms... Your comments and suggestions are welcomed.
Thanks in advance,

Phil

#7
 

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,947
Reaction score
4,104
Location
Western US
One more question. I usually fly Litchi software. Recently, I have noticed that my video feed is delayed. For example, if I make a controller input, such as yaw or climb, the video of the movement is delayed. This is very annoying and makes setting up a nice video shot nearly impossible. Well, I updated the drone and controller software yesterday. Everything flies great, but I still have the lagging video issue. Anyone else had this problem? I am ready to fly with the DJI software to see if the problem is with Litchi or if it is something in the video downlink as it would affect both platforms... Your comments and suggestions are welcomed.
Thanks in advance,

Phil

#7
If it were mine, I would be looking first at my mobile device.
 
  • Like
Reactions: Numone and JoBe
Joined
Nov 12, 2015
Messages
653
Reaction score
222
Age
40
The mini 4 is bad a$$ and has been one of the best to use. I've benn reading people are seeing issues with this new firmware and app on devices that used to work perfect. CPU Fully Loaded errors and lagging video. I have a Mini 2 and its making me nervouse. Are you flying in a hot area?
 
Joined
May 19, 2017
Messages
75
Reaction score
27
Age
63
My iPad mini 2 (model A1490) used to work great. That is, until I mistakenly did the Apple firmware update. Once I did that, the DJI GO would no longer even run. I uninstalled DJI GO, re-installed, and then it worked. But it installed the newer version of DJI GO! Now it complains all the time that I need to update the firmware on my Phantom 3 Advanced. I'm holding out as long as possible. I don't want it to disable any features, or lock me out from doing things that should ultimately be my choice. Since the update, I get the "CPU Fully Loaded error" as well. It seems to work, but the video is now laggy (it never used to be with the old version), even when I make sure there is nothing else running on the iPad.
 
  • Like
Reactions: JoBe
Joined
May 8, 2014
Messages
81
Reaction score
7
Age
72
Location
Indian Rocks Beach, FL
Here is what I found. I can fly with the DJI Go app, and the video stays locked in. No issues. So, the problem has to be in the Litchi app. My friend, Nick, who also has the Phantom 3 is experiencing the same problem as I am in Litchi. I am hopeful that the Litchi folks will be able to rectify this problem.
 
Joined
Jul 21, 2017
Messages
1
Reaction score
1
Age
51
I have the lagging once a while on Litchi or Phantom Go. My fix are to close the app and unplug the cable, then plug the cable back and start the app. It should be ok after that.
 
  • Like
Reactions: Phil H
Joined
Nov 12, 2015
Messages
653
Reaction score
222
Age
40
My iPad mini 2 (model A1490) used to work great. That is, until I mistakenly did the Apple firmware update. Once I did that, the DJI GO would no longer even run. I uninstalled DJI GO, re-installed, and then it worked. But it installed the newer version of DJI GO! Now it complains all the time that I need to update the firmware on my Phantom 3 Advanced. I'm holding out as long as possible. I don't want it to disable any features, or lock me out from doing things that should ultimately be my choice. Since the update, I get the "CPU Fully Loaded error" as well. It seems to work, but the video is now laggy (it never used to be with the old version), even when I make sure there is nothing else running on the iPad.
Yeah this is happening so much. Dji must have set the parameters differently and now require more power as a minimum. No other way to explain so many cpu fully loaded errors out if the blue. Also so many people lagging out of the blue. Not everyone suddenly has a bad SD card. As my nephew says, hashtag logical!
 
Joined
Jul 5, 2013
Messages
2,015
Reaction score
772
Age
59
Location
Warrenpoint, Ireland
Ok out flying last night - serious lag. 6/7 seconds and I was flying close to an old building with lots and lots of trees around. Never a good idea. I gave up after about four minutes of trying to remove the lag by closing apps, unplugging cables etc. Landed, swopped SD cards and back up in the air without turning anything off, just swopping over the SD card. Immediately removed any lag. Same everything else.

I'm convinced that the lag issues are down to the SD card being used.
 
  • Like
Reactions: Numone
Joined
Jan 10, 2016
Messages
2,513
Reaction score
815
Location
Surrey, England
After I download the content from the SD Card to my USB drive via the PC, I pop the card back into the 3A and then reformat the card. I dont even bother to erase the content; the format takes care of that and this effectively brings the card back to an "as new" condition. I've never had any "lag" issues and I've always used the same Class 10 64GB Transcend SD Card. I use an iPad Air 1 with the latest iOS and version of GO.
 
Joined
Jul 5, 2013
Messages
2,015
Reaction score
772
Age
59
Location
Warrenpoint, Ireland
Ok, same (good) SD card yesterday, serious lag again. Closed everything down, still the same. Thankfully I was only taking stills; video would have been impossible. Moved to a second location and with the same equipment, it was fine, then a few minutes into the flight, the lag reappeared. It really is a pain.

I'm on all the latest updates firmware wise, using DJI Gon in an iPhone 7 Plus. Getting stumped now.

Any ideas?
 
Joined
Sep 19, 2016
Messages
1,047
Reaction score
434
Ok, same (good) SD card yesterday, serious lag again. Closed everything down, still the same. Thankfully I was only taking stills; video would have been impossible. Moved to a second location and with the same equipment, it was fine, then a few minutes into the flight, the lag reappeared. It really is a pain.

I'm on all the latest updates firmware wise, using DJI Gon in an iPhone 7 Plus. Getting stumped now.

Any ideas?

If that's two SD cards that have seemingly brought on the lag symptoms, both intermittently, then my first thought would be about the connections that the SD card is making within its slot on the drone.

You could perhaps try cleaning the SD card terminals (with electrical contact cleaner spray and Q-tips) and the inside of the card slot with just the spray. There may be some crud on the connectors inside the card slot which is intermittently getting transferred onto the cards and preventing a good connection. That could (maybe) be using up extra processing resources, thus causing a slowdown in video processing/transmission as the drone struggles to write successfully to the card?

But use the spray very sparingly on the slot of course - and maybe carefully insert/remove the SD card a few times before the spray dries..

Even if it's not the cause, at least you should know for sure that it's not.

Another possibility is that there is some minute damage to the card slot connectors...
 
  • Like
Reactions: happydays

Recent Posts

Members online

No members online now.

Forum statistics

Threads
142,290
Messages
1,461,939
Members
104,061
Latest member
C simo