URGENT Begging for help - Firmware / RC linking issue

Joined
Nov 24, 2016
Messages
1
Reaction score
0
Age
30
I bought the Phantom 4 about 2 weeks ago from another person and during the testing, seems like he had some issue with the firmware thing.
Anyway, he seems to fixed it by rolling back to previous firmware version so i bought it.
However, everytime before I fly, i have to do RC Linking, which is so **** troublesome.
I did flew the drone successfully for 3 times, and on the 3rd time, Signal lost and almost crash but I managed to save it without a scratch.

Fast forward to 5 days ago, i brought this drone for on assignment. The **** RC linking did not work no matter what i try.
I also ntice on DJI Go app, it states the Firmware is the Latest (previosuly it when the drone was working, it says it needs update)>
I don't know how come it auto update itself.

Now i have spent 5 sleepless night (ok i did sleep but only avverage 4 hrs for past 5 nights while working 10 hours everyday on photo assignment)
Read all the forums and outube videos
tried all these
- Assistant 2 on Mac to update the Phantom 4 to latest firmware (RC linking still doesn't work)
- Same as above but downgrade Phantom 4 to older version ( RC linking doesn't work or the update just stops halfway)- Tried to downgrade Remote Control via DJI Go app on Samsung Note4, but it always tells me no firmware available for download. The version no for the remote control and Phantom 4 on the About section is also nil.
- Format my thumbdrive (FAT) and copyC1_FW_V01.05.0080.bin to the thumbdrive. Plug it in to Remote Controller and power on. Waited for a long time then hear the beeping sound. Restart remote controller again. Installed fresh new DJI Go app on Samsung Note 4. Tried RC linking, not working.

I really really really really need help. I am down on my knees begging for help.

Sorry needed to vent : Why the hell does this firmware thing sucks so much?
Why is it so problematic for so many Phantom users out there? I see people having issues since Phantom 3.
Why do i pay such a huge amount of $$$ on this thing, only to bring it for my photo assignment and does not work? I paid for it for nothing? Its so humiliating for me as i am on a job for an important org. Its been a nightmare... i only have a week left on this assignment in this country.

Sorry getting emo... lack of sleep and freaking tired.... and i have to head out for another full day shoot in 5 hrs.

Plesase help enlighten me and wake my Phantom 4 up ....
I needto sleep now, hopefully when i wake up i will get some good advice. Thank you.
 
Joined
Jul 13, 2016
Messages
352
Reaction score
111
Age
47
Location
MN
I feel your pain, I don't have the best answer for ya though, could you post what you have for a set up? I just updated all mine last night and everything went good, did some test flights and all working good
here's my set up:
ipad mini 2: 10.1.1 (14B100)
app: 3.1.0
ac: 01.02.0602
rc: 1.8
 

New Threads

Forum statistics

Threads
135,780
Messages
1,404,716
Members
98,856
Latest member
Pblacklock