Updating P4 firmware when drone and controller won't connect

Jul 1, 2016
Reaction score
After purchasing a new controller for my Phantom 4, I've tried to connect to the drone but no luck.
DJI assistant will still not recognise my Phantom and when asked to choose my device I’m offered only “A2” or “Ronin” to choose from. I read elsewhere that the latest version of DJI assistant does not work with iOS. I'm guessing this is still the case.

Further research told me it’s possible to upgrade my drones firmware via the DJI Go app. So I watched the DJI video on the subject and followed the steps to connect the drone to my mobile device (iPhone 12 Pro max) which has the DJI Go app.

But of course with old firmware on the drone and presumably new firmware on my new controller, there is no way the controller will connect with the drone.

So it would seem I can't connect the controller and the drone because of incompatible firmware and I can't upgrade the firmware because the drone and controller won't connect !!

So can anyone offer advise on how can I update my drones firmware and get flying again, when the drone and controller won't connect?

Any help help would be appreciated
  • Like
Reactions: 1EagleDave
You have all instructions on how to upgrade the firmware on YouTube or in this forum.
But, I suppose that you checked the compatibility of the controller and the drone at first.
This is true Andy and I've followed them to the letter without success. As for the compatibility of the controller, I know not of such things, (very much the pilot not a techie), but I'm assuming the "experts" do that sent me a new replacement controller instead of repairing my original.
But then again, we've all had less than spectacular results from experts right LOL! Thanks for your input.
  • Like
Reactions: 1EagleDave

Recent Posts

Members online

No members online now.

Forum statistics

Latest member