Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Update Firmware

Discussion in 'General Discussion' started by Bill Ferrett, Jul 27, 2016.

  1. Bill Ferrett

    Aug 1, 2015
    Likes Received:
    Last week I flew 2 batteries with no problems. But 3rd battery. I took off and display said something like "land now". Display also said upgrade required. I took it home and tried to fly and it worked for a while. Then I lost connection. Screen locked up and I was able to land just by viewing the aircraft. Ok after all that I tried to upgrade the A/C firmware, followed directions. After inserting SD a Card writhe the .bin file on it nothing happens. No sound like it always did. Cannot get RC and Aircraft to connect (ready to fly). I think I have tried everything. I even tried going back to 1.8. Any held will be appreciated.
  2. Sim597

    Mar 5, 2016
    Likes Received:
    whenever I've seen what seems like an anomaly, I tend to treat it that way. I've had my RC say firmware needs to be updated when it clearly doesn't need to be, then after a reboot or restart of app or whatever, glitch gone and problem solved. This seems beyond that, with you saying you flew it again. Why are you using SD card? Upgrade the firmware via the dji assistant like I did, or from the app, plug the bird into the RC and open app at MAIN screen, after a few moments the update should come up.
  3. Jeff watson

    May 15, 2016
    Likes Received:
    Email DJI with firmware problem. They will tell how to remedy your situation.

    Sent from my iPhone using PhantomPilots mobile app
Similar Threads - Update Firmware Forum Date
Any news on fixing firmware after last update? Phantom 4 Discussion Tuesday at 7:51 PM
P3P issues after firmware update Pro/Adv Discussion Tuesday at 2:49 PM
Latest firmware update Phantom 4 Help Tuesday at 1:37 PM
Huge problems after update of firmware Phantom 4 Help Monday at 3:36 PM
P4P Camera Sensor Error after firmware update Phantom 4 Pro Help Sunday at 4:47 PM