Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Tx won't bind, rc won't calbrate stuck in failsafe help plea

Discussion in 'Phantom 2 Vision Discussion' started by noiep2v, Jun 8, 2014.

  1. noiep2v

    Joined:
    Jun 1, 2014
    Messages:
    6
    Likes Received:
    0
    after crash about 15 feet. landed on its top ,battery pop out, camera hanging. put it back together, rapid blinking yellow. tried binding it and it did bind but after i shut it off and fully charge battery. started to rapidly blink again.now it won't bind, didn't see any loose connectors or solder when i open the P2V . tried the assist it failed the calibration of the TX the t won't stay green . firmware is updated also 3.04 ,its on d-bus . plus camera app is working properly it just stuck on failsafe and i can't fly. please help , thanks
     
  2. javierajuarez

    Joined:
    Nov 28, 2014
    Messages:
    3
    Likes Received:
    0
    Re: Tx won't bind, rc won't calbrate stuck in failsafe help

    i'm having the same issue my phantom after a crash just didn't received any signal from the Remote got back home try every pairing mode even reset it, got the top off and everything was in place nothing broken calibrate everything with the assistan on my Mac it when i turn the phantom on it just blinks yellow just from the back led's i order a new transmittor card but not sure if that's the issue.. (if the phantom would be a computer, the diganosis i would give is that the reciever from the phantom it went bad or broken) so still waiting for the new transmittor to test it! let me know if you already solve the problem to help me out wiht mine!
     
Loading...
Similar Threads - won't bind won't Forum Date
New Controller Won't Bind Phantom 4 Pro Help Feb 19, 2017
Standard weak signal, won't bind, flashing yellow. Phantom 3 Help Oct 29, 2016
P3 Firmware Phantom 3A won't bind with controller after latest update. Firmware Jul 18, 2016
Camera won't connect after binding Phantom 2 Vision Discussion Dec 30, 2014
New battery won't charge Phantom 4 Discussion Today at 6:24 PM