Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Telemetry - Yes, Video - No

Discussion in 'DJI Lightbridge' started by deseptacon, Sep 18, 2014.

  1. deseptacon

    Sep 18, 2014
    Likes Received:
    Hello All,

    I'm new to the hobby and I am seeking advice on how to resolve a problem where I am not receiving video information. Here is what I currently have:

    Two different Phantom 2 units. All updated to current software using Phantom 2 Vision Assistant 3.2 software.
    Two different Lightbridge ground and air units. All updated using the Lightbridge Assistant 1.3 software.
    Two different GoPro 3+ Hero cameras mounted on the DJI gimbles.
    Futaba T14SG radio
    Zeiss goggles

    So, I assemble the first unit following the instructions and in the end I have a fully functional unit.
    I then assemble the second unit following the same instructions and I end up with a unit that has everything EXCEPT video. I get full updated telemetry, just no picture.
    I've even tried switch the HDMI (in) from my working unit to the problem unit to see if it were either a GoPro issue or a cable issue and still no video. I've checked all settings from first unit to second, including Lightbridge air/ground and GoPro, but nothing seems to clear this up.

    Any ideas where to look that I missed?
Similar Threads - Telemetry Yes Video Forum Date
DJI Go shows full telemetry but will not talk to aircraft Pro/Adv Discussion Jan 7, 2018
Phantom 3 Pro - esc beeping and no telemetry Pro/Adv Discussion Dec 13, 2017
No VIDEO OR TELEMETRY Phantom 2 Vision + Discussion Nov 25, 2017
No VIDEO OR TELEMETRY Phantom 2 Vision + Help Nov 25, 2017
Weird app issue, no telemetry & no app response Standard Nov 23, 2017