Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Telemetry not working

Discussion in 'Phantom 2 Vision + Discussion' started by ds5384, Jul 15, 2014.

  1. ds5384

    Joined:
    Jul 15, 2014
    Messages:
    1
    Likes Received:
    0
    I have an P2V+ with fully updated firmware and iphone 5s and can't get my telemetry to show up, the camera will show the output video on the iphone and I can trigger the shutter and video recording but I don't get gps count, altimeter, speed, or battery. Also ground station doesn't work at all (failed to load) and i have no manual control of the gimbal. I've tried the app on a iphone 5 and it does the same thing, which i feel isolates the problem to the camera and not the app.

    Are there any tricks to resetting the camera or anything I'm missing? It's new so it has never worked. Thanks for the help.
     
Loading...
Similar Threads - Telemetry working Forum Date
No video live feed but RC & telemetry data working just fine. Pro/Adv Discussion Dec 2, 2015
Wifi and telemetry not working... Phantom 2 Vision Discussion Apr 17, 2015
Stop Working.. No Telemetry, Battery or GPS Status In App.. Phantom 2 Vision Discussion Sep 1, 2014
Telemetry to stay on? Phantom 2 Vision + Help Aug 5, 2017
Record telemetry video Phantom 4 Help Jun 18, 2017