Professional SOLVED: Live Video Feed is Intermittent

Joined
Jan 23, 2016
Messages
61
Reaction score
23
Age
43
Today, for the first time, my video feed would cut in and out. The distance didn't seem to matter as it was problematic up close and out as far as 1000'. Sometimes it would flicker and sometimes it might stay out for a minute or so. I tried shutting everything off and restarting, but nothing changed. All signal indicators were full strength even when the video feed was blank. I also switched from "auto" to "manual" channel selection, but that didn't seem to make any difference.
I have not upgraded any firmware since I bought it last October because everything was working so well. I have just over 17 hours and 94 flights on it. I haven't even upgraded the iOS software. Nothing has been changed in that regard.

I would welcome any suggestions you might have.
 
Joined
Jan 23, 2016
Messages
61
Reaction score
23
Age
43
Well I thought I would post how I found and fixed my problem in case someone else had a similar issue.

I did some trouble shooting and noticed in flight that certain bank angles caused the video feed to blank out. I took the props off so I could hold it better and duplicated this while holding it.

I also began to see that when the aircraft banked the gimbal mount moved some, and this moved the two grey ribbon cables that are attached to it. I gently wiggled the cables and found that the smaller cable that plugs into the Lightbridge module was causing the video signal to cut out. I ordered a cable set, replaced this cable and all is working normally again. Hope this helps someone else.
 

New Threads

Forum statistics

Threads
133,507
Messages
1,382,702
Members
97,438
Latest member
Daveriordan