Phantom 3 standard no image transmission

Joined
Oct 17, 2022
Messages
1
Reaction score
0
Age
35
Hi,

New user here. Recently turned on my Phantom 3 standard drone after about a year of inactivity. I updated the app and the firmware to the drone resulting from this update. When I start it up it displays the live camera feed for about 30 seconds and then gives me an error message saying “no image transmission”. I tried restarting the drone and RC and each time the same issue occurs. I know they must be linked as I keep getting that initial live video feed on my iPhone app, but then it always disappears. I can fly the drone no problem, I took it up for a few test flights just for fun, but can’t seem to get the video feed. I tried everything while airborne to see if I could get it to reconnect but no luck. Tried resetting the camera, removing the memory card in it, recalibrating etc, and nothing worked. Is it the firmware update that broke it perhaps? Again, seems weird I get an initial love feed for 20-30 seconds and then get the error message. Any help MUCH appreciated.
 

GFields

Moderator
Staff Member
Premium Pilot
Joined
Aug 25, 2016
Messages
650
Reaction score
410
Age
65
Location
Birmingham, Alabama, USA
Hi,

New user here. Recently turned on my Phantom 3 standard drone after about a year of inactivity. I updated the app and the firmware to the drone resulting from this update. When I start it up it displays the live camera feed for about 30 seconds and then gives me an error message saying “no image transmission”. I tried restarting the drone and RC and each time the same issue occurs. I know they must be linked as I keep getting that initial live video feed on my iPhone app, but then it always disappears. I can fly the drone no problem, I took it up for a few test flights just for fun, but can’t seem to get the video feed. I tried everything while airborne to see if I could get it to reconnect but no luck. Tried resetting the camera, removing the memory card in it, recalibrating etc, and nothing worked. Is it the firmware update that broke it perhaps? Again, seems weird I get an initial love feed for 20-30 seconds and then get the error message. Any help MUCH appreciated.
Greetings from Birmingham Alabama USA, welcome to the forum!

I'm going to move your post to another area for better results.
 

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,800
Reaction score
2,318
Age
71
Location
IRB, Fl
Why the update? Usually cause more problems than worth it. If android try roll back to previous firmware, if it worked before. DJI does not force updates.
 

Recent Posts

Members online

Forum statistics

Threads
142,370
Messages
1,461,899
Members
104,172
Latest member
schoolnetindia