Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Firmware RC Bricked after failed firmware update?

Discussion in 'Firmware' started by El Guapo, Oct 28, 2015.

  1. El Guapo

    Sep 8, 2015
    Likes Received:
    I tried updating the RC firmware to 1.4.30 via the DJI GO app, and it was still going after 15 minutes of beeping. I decided (stupidly!) to power off the RC and try again.

    Now the RC does not beep when powering up and just shows a light-blue LED (not darker blue like when the firmware was updating. DJI app does not see it.

    Any chance to recover the RC after I stupidly interrupted it?
  2. PhantomState

    Feb 20, 2014
    Likes Received:
    I did the same thing last week and was able to complete the update. I read in this forum somewhere to turn on the P3P and let it sit. It'll continue the update after a few minutes. That's what I did and it worked. Have made a couple of flights since w/o any issues. Good luck!!
  3. Steve_in_NJ

    Aug 23, 2014
    Likes Received:
    Did you ever have any resolution to the problem? The same thing happened to me. I tried three times to install new firmware, each time getting closer. The radio was allowed to beep for a LONG time each try. Now the radio powers up on only ONE push of the power button and I get the light blue light next to the four white lights, and it cannot connect to the P3. First DJI tried to talk me through downgrading the firmware - didn't work. Now DJI wants me to ship it to them. I know that'll take forever.
Similar Threads - Bricked failed firmware Forum Date
P2 DJ6 Transmitter bricked after failed firmware upgrade General Discussion Nov 8, 2016
P2V Camera Bricked on Failed Firmware Update Firmware Jan 4, 2014
Professional P3P bricked and FW failed upgrade Phantom 3 Help Aug 19, 2017
Advanced Updated software and controller bricked Phantom 3 Help Oct 8, 2017
P2 Firmware Bricked RC after update Firmware Sep 12, 2017