Phantom 2 Vision + = Slow blinking red and yellow rear LED's - no motors?

Joined
Dec 30, 2021
Messages
4
Reaction score
1
Age
40
Hi all,

I have just picked up a 2nd hand Phantom 2 Vision + from eBay, listed as fully working but clearly isn't, no idea of the history of it, so could be impact damage or anything.

When I power it on, I get the musical beeps, it flashes through the self test and then starts slowly blinking the left 3 LEDs yellow and the right 3 LEDs red, and it makes what I first thought were 2 beeps, but I have now realized the sound is coming from the camera gimbal motors,

I can get the drone and controller to show up in the v3.8 software, shows the firmware, can do calibration etc and the controller sliders move in the app when I move the levers, but it just won't get past this slow flash stage.

Before I send it back, I'm wondering if anyone has seen this issue, as I've searched online and can't find any mention of this particular LED combination?

Video of startup:

(Top cover is loose in video as I opened it up to check for broken wires or loose connectors etc)
 

Attachments

  • 20211230_215105.jpg
    20211230_215105.jpg
    5.2 MB · Views: 34
  • 20211230_215112.jpg
    20211230_215112.jpg
    5.2 MB · Views: 30
  • 20211230_215127.jpg
    20211230_215127.jpg
    5 MB · Views: 31
  • 20211230_215135.jpg
    20211230_215135.jpg
    5.1 MB · Views: 32
Joined
Feb 23, 2014
Messages
693
Reaction score
178
Location
Santa Barbara County, California, USA
Hi all,

I have just picked up a 2nd hand Phantom 2 Vision + from eBay, listed as fully working but clearly isn't, no idea of the history of it, so could be impact damage or anything.

When I power it on, I get the musical beeps, it flashes through the self test and then starts slowly blinking the left 3 LEDs yellow and the right 3 LEDs red, and it makes what I first thought were 2 beeps, but I have now realized the sound is coming from the camera gimbal motors,

I can get the drone and controller to show up in the v3.8 software, shows the firmware, can do calibration etc and the controller sliders move in the app when I move the levers, but it just won't get past this slow flash stage.

Before I send it back, I'm wondering if anyone has seen this issue, as I've searched online and can't find any mention of this particular LED combination?

Video of startup:

(Top cover is loose in video as I opened it up to check for broken wires or loose connectors etc)
Is your wifi extender attached and fully charged?
 
Joined
Dec 30, 2021
Messages
4
Reaction score
1
Age
40
Yes, I can see the wifi connection and connect to it via the app on my phone, not able to get an image from the camera however (though I believe that's a whole other issue in itself?)

2021-12-31 12.47.25.jpg
2021-12-31 12.47.11.jpg


Is the drone inextricably linked to the camera in such a way that if the camera is faulty it stops the drone working at all?
 
Last edited:
Joined
Feb 23, 2014
Messages
693
Reaction score
178
Location
Santa Barbara County, California, USA
Yes, I can see the wifi connection and connect to it via the app on my phone, not able to get an image from the camera however (though I believe that's a whole other issue in itself?)

View attachment 123332 View attachment 123331

Is the drone inextricably linked to the camera in such a way that if the camera is faulty it stops the drone working at all?
No, my P2V connects, flies just fine, and takes pictures even though I no longer get an image on my iPhone of what I am photographing. The lost connection message suggests, but does not prove, that the Phantom wants to see satellites. It appears that you are trying to get connection indoors, so with the wifi extender and battery fully charged (green lights), try to start up the Phantom outdoors in the following sequence: first controller, second battery, third wifi extender. It's worth a try.
 
Joined
Dec 30, 2021
Messages
4
Reaction score
1
Age
40
Hi, thanks for the reply

I had tried outside earlier in the day, the video was shot after about 4 hours of trying to get it working inside and outside but it was dark and raining by then,
Tried it again outside today after your reply, it did eventually stop the red and yellow flash and start slow green flashing, just on the left side.
Manual says this is "Ready to fly" so I was hopeful but still nothing, controller doesn't do anything, no motor movement, no change in LEDs from the slow green.
The app still doesn't show the camera feed but shows the WiFi extender icon as blue but everything above it, including the satellite number, is greyed out,
 
Joined
Feb 23, 2014
Messages
693
Reaction score
178
Location
Santa Barbara County, California, USA
I have now sent this back and got a refund, I'll be looking at a newer model in future
You got a refund! Good for you. Let us know what newer model you eventually acquire. Good luck.
 

New Threads

Members online

Forum statistics

Threads
141,844
Messages
1,458,652
Members
103,632
Latest member
Bee aps