Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

phantom 1.1.1 help

Discussion in 'General Discussion' started by shuddna, Sep 4, 2015.

  1. shuddna

    Feb 28, 2015
    Likes Received:
    hello, well awhile back by phantom decided to go for a swim.. I have tried (and spent more money than just purchasing a new one) to rebuild it myself starting with the least expensive parts first, well i have now purchased everything, and it's all new.. the problem is that it's not flying..
    remote controller is paired and communicating..
    it is picking up gps
    it will not calibrate the compass
    it will not start the motors
    and in the assistant hardware, i can't test the motors..

    now the only thing i have replaced which is not the original is the naza.. i converted to the lite version because of the expense.. I have connected all the connections the same as the original..

    appreciate any advice (please use layman terms).. hahha

  2. BlackOpsTeamster

    Aug 12, 2014
    Likes Received:
    St. Louis metro east
    Welcome to the Forum!
    You'd probably get more replies if you posted this in the Phantom 1 section of the forum.
    Have you tried to calibrate the IMU? Take a look at this video. Good info here.

Similar Threads - phantom help Forum Date
Buying Phantom 4? (Newbie plz help) Phantom 4 Discussion Today at 12:28 AM
Need help with Phantom 4 Pro Phantom 4 Pro Discussion Yesterday at 12:37 PM
phantom fc40 help needed please ? Phantom FC40 Help Thursday at 2:07 PM
Phantom 3 standard no SSID help Standard/4k Discussion Wednesday at 9:33 AM
Newbie! Need help how to tell what model dji phantom I have General Discussion Aug 10, 2017