Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 1.1.1 after update no TX, rapid yellow- solution

Discussion in 'Phantom 1 Help' started by Imabiggles, Oct 11, 2013.

  1. Imabiggles

    Oct 11, 2013
    Likes Received:
    Got my phantom 1.1.1 - when I plugged it into the software it made me update to V4 firmware before it would let me click on any of the tabs (had to calibrate). When I did, I did the advanced calibration - took it out to the field to calibrate the compass but all I got were rapid yellows (no TX signal). Well hell. Looked at a bunch of sources, reset to stock. Loaded default. still no joy. Finally found a source that said if you have a new phantom (has two antenna) then you have to select d-bus for tx type. That fixed it and off I flew and burned through a couple of battery packs.

    Just posting here in case others have the same issue
  2. colproductions

    Oct 2, 2013
    Likes Received:
    Thanks, I'll give this a try. I've been fighting with it for two days now.

  3. cczx14r

    Sep 27, 2013
    Likes Received:
    HA! I'll be darned! You answered my question for me. I received my brand new V1.1.1 Phantom two days ago and towards the end of the V4.0 upgrade, I also got that rapidly flashing yellow (no Tx signal) LED. I scratched my head for 20 minutes and finally, just to see what would happen, changed the receiver type to D-Bus and she worked for me just like for you! Flies like a dream! I hope others that will be receiving their 1.1.1 Phantoms, see this thread
Similar Threads - Phantom update rapid Forum Date
Phantom 4k drone will not update Standard/4k Discussion Thursday at 12:09 AM
Phantom 3SE Update Issue Standard/4k Discussion Aug 13, 2017
P4 Firmware Phantom 4 pro plus no signal after latest update. Firmware Jul 31, 2017
Phantom 4 Failed update? Phantom 4 Help Jul 31, 2017
Calibration of Phantom 4 Pro since update Phantom 4 Pro Help Jul 29, 2017