P4P2 Controller Inop from Alientech antenna install?

Joined
Apr 4, 2020
Messages
2
Reaction score
0
Age
64
Hello, I hope you can help me. I have a bit of self induced problem. Last night, I attempted to install the Alientech antenna duo on my P4P2 controller. As I researched guidance for this endeavor, I did not find anything up to date. The phantom controllers that were being worked on were from previous versions. So, after eventually taking the controller apart, I replace the both antenna leads. It is not a complicated process. It does require unplugging several ribbon cables and plug connectors to accomplish this replacement. It is also a little difficult to reach in to disconnect one of the main ribbon cables. I found out that you can preclude all this by taking off the bottom switch and USB plug circuit board first. Anyhow, I reassembled the controller and turned it on. The results are as followed:

1. Constant repetitive beeping. - What is does this signify?

2. Can not connect controller to Phantom.

3. Can not connect the controller to my computer with USB to DJI Assist. Thus, no hard reset. (Cable Chks Good)

4. Can not connect the controller to display with USB cable. (Crystal Sky monitor)

5. Found a soft rubber insert and don't know where it goes. (Picture).

I have done the following:

1. Triple checked that all ribbon cables are in good condition.
2. Ensured that all ribbon cable connections are fully seated.
3. Ensured all Plug connections are fully seated.
4. Inspected for any type of damage of any parts.


Prior to this point, when I first got this platform, I got this error intermittently. I found out I needed to calibrate my controllers, which solved the problem. Has anyone done this install? Any ideas on what to do?

Thanks in advance!

Jack



20200502_070057.jpg
 
Last edited:

New Threads

Forum statistics

Threads
140,490
Messages
1,448,176
Members
102,285
Latest member
brotherb3