P4P Gimbal twitch?

Joined
Mar 29, 2016
Messages
1,724
Reaction score
502
Age
57
Had my P4P now for 2-3 weeks now. Been so cold have not flown much. But on a couple of occasions I have noticed that when I come to a stop in P mode I have gotten a gimble glitch or a twitch I'll say. Not an abrupt stop either. Just kind of a slow come to a stop. Only noticed it a couple of times so far. Anyone else had this or noticed it at all?
 
Joined
Dec 4, 2016
Messages
563
Reaction score
309
Age
44
Had my P4P now for 2-3 weeks now. Been so cold have not flown much. But on a couple of occasions I have noticed that when I come to a stop in P mode I have gotten a gimble glitch or a twitch I'll say. Not an abrupt stop either. Just kind of a slow come to a stop. Only noticed it a couple of times so far. Anyone else had this or noticed it at all?
Could you post a short sample? I do not think I have seen this.
 
Joined
Mar 29, 2016
Messages
1,724
Reaction score
502
Age
57
Here you Tomas.
This was over a week ago. I had it do it again yesterday as I came to a stop too. I didn't save the clip from yesterday. It's very subtle but it's there.
 
Joined
Dec 4, 2016
Messages
563
Reaction score
309
Age
44
That was definately noticeable. I have not seen this in my footage, but will try some fast stops tomorrow.
 
Joined
Mar 29, 2016
Messages
1,724
Reaction score
502
Age
57
That was definately noticeable. I have not seen this in my footage, but will try some fast stops tomorrow.
And to be honest Tomas, it's not really happening on fast stops. Just a pretty natural smooth stop. It was windy on the snow day. But yesterday it was very calm. Wind shouldn't cause a twitch like that anyway. Thx man.
 
Joined
Jul 26, 2016
Messages
1,539
Reaction score
479
Try turning off the VPS. Might help as I've noticed mine jerking a bit when flying into sunrise, but smoother when flying away. Maybe some contrast thing going on confusing it. Dunno.
 
  • Like
Reactions: KevMo Photog

GadgetGuy

Premium Pilot
Joined
Jun 18, 2015
Messages
6,778
Reaction score
2,148
My recorded P4P camera view flipped nearly sideways several times for a second or so during mild left turns in windy conditions! Definitely more of a jerk than a twitch! Coincided with a "maximum gimbal angle reached" error message on the screen! My original P4 did this, too. I returned it. This one is going back, too! Gimbal ribbon cable must be rubbing or camera must be slamming against the frame. Definitely not normal, or tolerable! :rolleyes: Unfortunately, I cannot reproduce any inappropriate contact while manually manipulating the camera on the ground with the power off. Puzzling, but not my job to fix!
 
Joined
Jun 28, 2015
Messages
174
Reaction score
38
What do you think about this ???
No winds, Normal mode, normal everything - apart from the new Phantom 4 Pro.
 
Joined
Jan 25, 2016
Messages
99
Reaction score
30
What do you think about this ???
I had something very similar happen with my P3A several months ago. I came to the conclusion, admittedly with no hard evidence other than the fact that they're common in the area in which i was flying, that it was a minor cyclone or dust devil of some kind. Here's the cached clip:




Sent from my iPad using PhantomPilots
 
Joined
Mar 29, 2016
Messages
1,724
Reaction score
502
Age
57
Wow to both the last post! Def is something going on that needs to be fixed obviously with next update.
 

ianwood

Taco Wrangler
Joined
Jan 7, 2014
Messages
5,109
Reaction score
2,042
Location
Lost Angeles
These both look different than the twitch that the OP is seeing. These look like the gimbal (note the spelling) is getting overloaded and the motors give up briefly. Could indicate bad motor, bad balance or something else. Unclear.

The twitch the OP is seeing looks more like a sensor related issue, either compass or IMU. Occasional and small but definitely ruining shots. I am seeing it as well. Apparently, DJI is aware of it and will be trying to fix it in a firmware update.
 
  • Like
Reactions: KevMo Photog

GadgetGuy

Premium Pilot
Joined
Jun 18, 2015
Messages
6,778
Reaction score
2,148
What do you think about this ???
No winds, Normal mode, normal everything - apart from the new Phantom 4 Pro.
All three of my P4P's exhibit this bizarre gimbal flip, some more frequently than others, usually during slow, left banking turns! "Could indicate bad motor, bad balance or something else." Agreed! Not likely to be fixed by a firmware update. The twitches are also present.
 
Joined
Dec 5, 2016
Messages
995
Reaction score
291
Age
37
All three of my P4P's exhibit this bizarre gimbal flip, some more frequently than others, usually during slow, left banking turns! "Could indicate bad motor, bad balance or something else." Agreed! Not likely to be fixed by a firmware update. The twitches are also present.
I can't imagine the rotten luck to have 3 that do this? That's just awful. :(
 

GadgetGuy

Premium Pilot
Joined
Jun 18, 2015
Messages
6,778
Reaction score
2,148
I can't imagine the rotten luck to have 3 that do this? That's just awful. :(
Agreed! Same batch from B&H, so they likely all came from the same assembly line at the same time. So when you you do a banking left turn, or a counterwise orbit, this never happens on yours?
 
Joined
Dec 5, 2016
Messages
995
Reaction score
291
Age
37
Agreed! Same batch from B&H, so they likely all came from the same assembly line at the same time. So when you you do a banking left turn, or a counterwise orbit, this never happens on yours?
My gimbal has been solid no matter what I throw at it.
 

New Threads

Forum statistics

Threads
135,781
Messages
1,404,707
Members
98,855
Latest member
johnvanlit