P3 4K Problems may need gimbal main board Anyone have a spare?

Joined
Dec 7, 2020
Messages
3
Reaction score
0
Age
55
Location
Philadelphia, PA USA
Website
www.youtube.com
Hello I had bought a P3 4K used with the knowledge it did crash and the camera needed work. Guy assumed it was the cable. Drone shows no damage from crash and I have now replaced the cable twice to be certain issue is not from inexpensive cable used. Gimbal does standard start up dance but no image and does not recognize and sd card inserted. Like to get this drone repaired as have 8 going on 9 phantoms 7 are various versions of the 3 series. Unfortunately only have one 4K version so lack opportunity to swap parts to find problem. Any help with this is welcome and thank you.
 
Joined
May 13, 2021
Messages
1
Reaction score
0
Age
41
Hi. Same problem here on a P3P. I had replaced the data strip once before due to damage. This time it was damaged during transport, camera completely disconnected from one of the axis and broke, so I replaced the strip again. gimble does the startup dance but no video feed. Bird responds to controls, tilts and calibrates gimbal and powers props. Checked the card as other forums said that a bad or full card can cause issues. turns out the card is good, and was almost empty... Now I go and check the gimble main board (the big one where the grey cables that go to the rest of the bird). I find no visible issues, but noticed that if I plug the usb cable from the side to the PC, (as when to go dump the card directly from the bird) that the card mounts and dismounts continuously, which leads me to believe that the gimbal main board has some kind of issue, also, when shutting down the drone, the battery button blinks red for a bit before finishing powering down. According the forums, the blinking indicates that the drone is trying to save some data, but as the card is not responding properly, the red blinking occurs. I' am planning to replace the gimbal main board and see if it works for me.


Hope you can get yours fixed.
 
Joined
May 15, 2021
Messages
2
Reaction score
0
Age
29
Yes it is gimbal board need replace. but becareful when buy the used one, it maybe have the same problem
 

KachemakDiver

Premium Pilot
Joined
May 15, 2019
Messages
1,151
Reaction score
783
Age
58
Location
Homer,Alaska
Hi. Same problem here on a P3P. I had replaced the data strip once before due to damage. This time it was damaged during transport, camera completely disconnected from one of the axis and broke, so I replaced the strip again. gimble does the startup dance but no video feed. Bird responds to controls, tilts and calibrates gimbal and powers props. Checked the card as other forums said that a bad or full card can cause issues. turns out the card is good, and was almost empty... Now I go and check the gimble main board (the big one where the grey cables that go to the rest of the bird). I find no visible issues, but noticed that if I plug the usb cable from the side to the PC, (as when to go dump the card directly from the bird) that the card mounts and dismounts continuously, which leads me to believe that the gimbal main board has some kind of issue, also, when shutting down the drone, the battery button blinks red for a bit before finishing powering down. According the forums, the blinking indicates that the drone is trying to save some data, but as the card is not responding properly, the red blinking occurs. I' am planning to replace the gimbal main board and see if it works for me.


Hope you can get yours fixed.
You might want to think twice about gimbal boards from China. A friend and I have tried multiple times with them and 5 out of 5 boards did not work! Your board may just needs to be reflashed. Did you use a OEM DJI cable?
 
  • Like
Reactions: Oso

New Threads

Members online

Forum statistics

Threads
140,752
Messages
1,450,502
Members
102,587
Latest member
Blufx