Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P2 battery problem - not charging

Discussion in 'Phantom 2 Discussion' started by iversens, Mar 9, 2014.

  1. iversens

    Jan 22, 2014
    Likes Received:
    San Jose, CA
    Hoping someone can help me debug my P2 battery problem.

    Flew my P2 a couple days ago down to about 50% on the battery. Pulled out the battery and tried to charge it, but it's not working.

    Battery now turns on with just one button push and just the two middle LED's are on. Outside LED's are off. Normal double button push to turn on/off doesn't work.

    Battery does not charge when plugged into charger. Only two middle LED's light up and stay solid.

    P2 assistant (1.08) seems to show corrupt data coming from the battery? I'm assuming this means it's bad now, but I"m hoping I can recover it.

    I tried discharging the battery by starting the motors, but they won't start even with CSC. Just get a quick red flash on the P2 LED's each time I try a CSC.

    Any ideas?

    I only have about a dozen flights on my P2.


    Phantom v2, Zenmuse H3-2D, GoPro Hero3 Black

    Attached Files:

  2. SRT


    Feb 19, 2014
    Likes Received:
    Somewhere in the Appalachian Mountains
    Looks like the memory chip of the battery is bad. I don't think anyone has done any battery hacking yet since these are so new.

    How long have you have the Phantom? You might be able to get this replaced under warranty.
  3. atxpackfan

    Jul 3, 2014
    Likes Received:
    I am going to guess it's the rom module in the battery controller. The EXACT thing just happened to me. I've had zero problems with my Vision + for 4 months of flying. I went through upgrade process on aircraft (main controller,P330CB, IMU and apparently and unfortunately...the battery.) It failed to write update to battery...told me to power cycle...I did...same thing...now it says it has but it doesn't function other than the initial start..I get no motors...no gimbal...no compass..
    I am not sure of my warranty status...I am hoping to take it in to local DJI retailer and get it fixed or replaced.
  4. RDCF550

    Oct 22, 2014
    Likes Received:
    USA, VA
    I've done some messing with the battery pack, and that's a right interesting error for it to have 5911 in that many places. Is it still reporting that it's a DJI battery? or are you getting the Not DJI Intelligent Battery! error in the assistant?

    The 2 middle LEDs being lit is close to what it does when an update is taking place as well, so it's gotten into some pretty jacked up state there, which I'm surprise isn't happening more with these things as that update seems to have been for the newer battery that isn't out yet. I have a semi bricked battery here from that 2.6 update fiasco that throws error[33] and will not work with a 3.08 board, but it does if the board is downgraded to 1.08, just an awful 'update' it was.

    http://www.rcgroups.com/forums/showthre ... st29678247

    If you're stuck with the thing PM me, I'd be interested in taking a look at it, but no guarantee as to what might come from it as that's a new one on me.
Similar Threads - battery problem charging Forum Date
Battery/Charging Problems Phantom 2 Vision + Help Jan 9, 2017
Charging Battery Problem Phantom 2 Vision + Discussion May 10, 2014
Battery charging problem Phantom 2 Discussion Mar 22, 2014
Battery problem ? Standard/4k Discussion Jul 20, 2017
p4 battery problem Phantom 4 Help Jun 13, 2017