New iPad--DJI Go App Disconnected

Apr 22, 2016
Reaction score
Orange County, CA, USA
I had a problem today and I wanted to share what happened and how I solved it, in case anyone else runs into this issue.

I've had my Phantom 4 for about 3 weeks now and I use an iPad Air as the display for the DJI Go app. It worked well. Yesterday, I bought a new iPad, the iPad Pro 9.7". I did the usual save the old iPad to iCloud and restored the backup to the new iPad. No problems.

However, when I pulled up the DJI Go app the first time, it said "Disconnected." I had the aircraft on, I had the remote on, and I had the app up. I went through the instructions on how to connect, but it wouldn't do it.

I read through quite a few posts here and on the DJI Web site forums on what to do in similar situations, but none of them helped. I tried deleting the app and reinstalling it. I cleared the cache. I restarted everything several times. I tried anything anyone else had done. My iPhone connected fine with the same USB cable, but the new iPad wouldn't connect.

Finally, what I noticed is that my new iPad had been shipped with iOS 9.3. My old iPad had 9.3.1 on it when I installed the DJI GO app. So I updated iOS on my new iPad to 9.3.1 and the DJI GO app immediately worked. It connected, I flew, everybody was happy. Why this is true, I don't know, but that's what I went through and what worked for me.

As I said, I'm providing this information in case anyone runs into a similar situation.
Feb 28, 2016
Reaction score
I had the same problem, but I was using samsung. Go app connected on my note 5. But my 8 inch tablet would not. I tried everything. Finally I talk to a tech on line, told him my problem I had a p3s and upgraded to a p3a. He had my use a different cable and poof it hooked up. I tried thar the night before didn't work. Does now, so I don't know what happened but it's working. I'm happy

New Threads

Forum statistics

Latest member
Carl gould