Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

need help from someone taranis smart

Discussion in 'General Discussion' started by thetac, Feb 1, 2014.

  1. thetac

    Sep 9, 2013
    Likes Received:
    I have an older phantom that i put a taranis in with x8r receiver....worked like a champ, with sound, with file uploaded from other discussion on this forum. So i decided to upgrade my phantom and stuck a v2naza with GPS puck(i was thinking my retracts would not affect the puck as they do the magnetic compass). Here's my problem the phantom board is/was plugged into the x3 of the naza.....i had to unplug it to plug in the pmu of the V2(which says plug into the x3)....which i did.....so now the board plug is not plugged in to anything. I ran everything on the naza assistant and everything checks out fine. I did the compass dance and basic and advanced calibration all is ok. The issue is after it goes through the start up sequence and i start getting the green-green...green-green etc. I go to start the motors and nothing! I think that i should have left the board plugged into the naza x3 and plugged the pmu into one of the channels of the x8r...but i'm not sure which one. Anybody with any ideas? I know this is not the typical setup because normally someone wouldn't waste $300 on a v2 and puck and retro it to an old phantom....but alas i am not normal!

Similar Threads - need help someone Forum Date
Someone close to me need help Phantom 4 Help Sep 13, 2016
help someone in need Classifieds Aug 9, 2015
DJI GO APP (Need help on editing) Phantom 4 Pro Help Yesterday at 5:16 PM
phantom fc40 help needed please ? Phantom FC40 Help Yesterday at 2:07 PM
Help needed on Pro+ Editor feature. Phantom 4 Pro Help Yesterday at 12:27 PM