Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Mini-iOSD Problem!

Discussion in 'FPV (First Person View)' started by Crank, Jan 7, 2015.

  1. Crank

    Oct 26, 2014
    Likes Received:
    I've been working on my Mini-iOSD problem for the last 3 days.
    I have a P2 Ver. 1.0, Black Pearl monitor, 600mw transmitter. I get a blank screen. No video or OSD info. If I run the camera video direct to the transmitter, I see video. I replaced the video in/out cable to the Mini-iOSD. No dice. I've checked my wiring over and over again. My question is my NAZA. I don't see the V2 printed on the NAZA label. It just says NAZA. See attached picture.
    I'm also going to add the BTU and Data ground station. If my NAZA Version is the problem, I may be in bigger problems.

    Attached Files:

  2. QYV


    Apr 1, 2014
    Likes Received:
    did you make your own cable or did you buy a pre-made cable that connects the mainboard, iOSD Mini and transmitter together?

    "if I run the camera video direct to the transmitter" - do you mean USB from the GoPro straight to the Tx, or do you plug in a Zenmuse gimbal and get video signal from the Phantom mainboard?
Similar Threads - Mini iOSD Problem Forum Date
F550 with DJI Ground station and mini iOSD problems Other DJI Multi-Rotors Nov 16, 2016
problem with pmu and iosd mini on phantom 1.1.1 Phantom 1 Help Aug 1, 2015
Phantom 2 with iosd mini and AVL58 problems Phantom 2 Help May 3, 2015
Problem with black pearl and mini iosd FPV (First Person View) Feb 3, 2015
iOSD mini problem FPV (First Person View) Aug 20, 2014