Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. Jussaguy

    Jan 19, 2016
    Likes Received:
    Sorry if dupe. By the way, when the P4 returns to the homepoint, I'm finding (probably due to the duel IMUs and compasses) that it's landing on the dime it took off on BUT:

    I was up on Mulholland Drive the other day where you can get a beautiful vista by just flying off the cliff.

    Immediately upon doing so, you're a thousand feet above the valley so i usually head straight down.

    I have been keeping in VLOS lately because I am not yet trusting the P4 enough to do otherwise (and its the law :) ).

    It was a super bright day and I wanted to see my distance, so I looked down and when I looked up, I could not see the bird. So I did a RTH.

    Waited a min and after not really noticing that it wasn't doing and then it wanted to land! I know the manual says it will automatically land if you are in a 20 meter radius of the homepoint (something I've never understood but I was much farther than 20 meters away and it wanted to land). I kept trying it over and over and it kept trying to land.

    It also says in the manual (although I didn't know it) but I tried to override that by using the throttle and it says in the manual that indeed if you do that, it will dis-engage descending and return to homepoint.

    My question is two fold, why in all my time flying the P3P and P3A have I never once encountered this issue abd two, WHY DOES IT EXIST? Even if I'm 65 feet away, when I say RTH, why would it land instead of RTH???

    Either way, I was DEFINITELY FARTHER THAN 20 meters (65 feet) so I stopped, and for the first time in about a year, I was in a panic mode and had to work myself out of it. By the way, my method for getting out of panic mode is to just admit to myself it's gone forever and work from there.

    As it turns out, that was almost the case.

    The bird was low in the valley and I had NO IDEA where it was in relation to the visual (it was super bright and had no shade on my Mini) so I just made the map full screen (switched to Atti mode), ascended to a level that I knew was about 30 meters above my starting point and followed the map back and then descended and hoped for the best.

    I was down to about 5% battery at that point and was already thinking about what my next step was going to be when all of a sudden I could hear the motors.

    I put it in S mode for some extra speed and descended as fast as I could and thank God because when I caught it, there was 2% left.

    I NEVER EVER return a bird with less than 15%.

    This was BY FAR my closest call and if there was some pilot error, I haven't a clue where it was.

    I have it all recorded and will upload it to this thread later along with the flight info and I'll upload the logs, but the fact that I still own a P4 is either dumb luck combined with half decent pilot skills, or dumb luck caused by poor pilot skills. I have yet to determine which.

    Leaving on an Easter trip with the family so I wont have a lot of time to study the flight data this weekend but I'm bringing the P3 and another one and leaving the P4 home because I won't fly it again until I know what happens and without a satisfactory answer or the thing I did wrong, this is going back home.

    I already called DJI and they said I could return the care but not the two batteries I just bought so if I don't get an answer, two brand new batteries will be for sale.

    Not for nothing, the DJI tech I spoke with on the ride home to discuss the issue said he had heard about this issue from some of his colleagues but I was the first case to have come to him with it.

    (Sorry that I am not proof-reading this now and typos is my best business).
    #1 Jussaguy, Mar 25, 2016
    Last edited: Mar 25, 2016
  2. sar104

    Mar 22, 2014
    Likes Received:
    Los Alamos, NM.
    Was the home point properly set before takeoff?
  3. msinger

    Approved Vendor

    Oct 30, 2014
    Likes Received:
    Harrisburg, PA (US)
    Please upload your flight log here and post a link back here.
  4. Ramphex

    Mar 19, 2016
    Likes Received:
    Sorry to hear about the close call buddy. Personally I never tried to return to home from a lower altitude but as far as I'm aware it's supposed to raise to your set RTH altitude and then travel over to the home spot and then land.

    Was your home locked on GPS in the correct spot?
  5. Jussaguy

    Jan 19, 2016
    Likes Received:
    I HATE more than I can say that they buried the homepoint setting into the MC settings now so you don't have homepoint options (even on a larger display on the screen) but yes, I did that and set the homepoint. It also sets a homepoint automatically whether you start the engines, or just do an auto take-off so it's pretty hard not to set a homepoint. I should have said that while the problem was happening, I had the wherewithal to set a new dynamic homepoint at the RC (which really just set the homepoint at the same point). The homepoint was in the proper spot. I could see the blue dot and the yellow little homepoint thing so there WAS definitely a homepoint in the right spot. I could look at the map and see that.

    I will as soon as I get back on Sunday. My first thought was that my bearings were off (and in fact they were) but I mean to the point where I was just confused by the valley and the height. In fact, now that I am thinking about it, maybe that's a bug in the new software. When I start off I am on a cliff at 0m and then when I take off and go say 10m up, once I go forward, I am literally over 1000 feet in the air over the valley. I have done this a million times with the P3P and the Inspire and it's never been an issue but this is the first time with the P4 and the new firmware and (new app) and maybe it was confused by being lower than the original homepoint?

    I'm just spitting here I realize but at that point, maybe I should turn off the VPS because it is maybe coded poorly for that and it thinks it should be on the ground and it's not, so it wants to land? Again, making slightly educated guesses here but since I have not had a problem with the P4 (although only a few flights), I'm thinking whether mine or the apps fault, the going below the 0m homepoint somehow screwed it up.

    By the way, I should have also said, that I immediately sent the bird back up with another battery (kind of like getting right back on your snowboard after a nasty fall) but I wouldn't send it out of anywhere near my sight and never took my eyes off of it and sent it over the mountain, rather than the valley and the RTH worked perfectly about 5x in a row. That's all I was doing, was launching and RTHing.

  6. maseman88

    Mar 23, 2016
    Likes Received:
    Mine works every time... no matter how far away or what altitude.
Similar Threads - Landing RTH (is Forum Date
Tired of hard landing with RTH Phantom 4 Discussion Mar 28, 2017
Critical battery-landing mode- rth? Yes/no? Pro/Adv Discussion Jan 25, 2017
Standard AutoLand with out RTH, stoplanding failed Phantom 3 Help Jan 16, 2017
RTH after landing? General Discussion Oct 25, 2016
Landing Bombardier in Russia the northern city Noyabrsk Photos and Video Sep 14, 2016