Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Just received P3P, trouble with firmware :(

Discussion in 'Pro/Adv Discussion' started by Indy443, Sep 25, 2015.

  1. Indy443

    Sep 24, 2015
    Likes Received:
    I just received my P3P this afternoon. After charging the battery and the controller I went to update the firmware as the pilot app said it needed it. I went to DJI site, naviagted to the P3P site and downloaded the latest firmware pack. Got that loaded onto my micro SD, inserted it in, turned it on. Everything seemed to be going along just fine: getting the short beeps from the gimbal, flashing red and green small LED on the gimbal, occasional chirps from the gimbal....after 20 minutes everything turned red and it emitted a continuous harsh beep. The txt file said the update had failed :(

    Now I have tried multiple different times, including re-downloading the pack from the DJI site but still the same result. Getting a bit freaked now. Please help!
  2. Meta4

    Meta4 Moderator
    Staff Member

    Jan 8, 2014
    Likes Received:
Similar Threads - received P3P trouble Forum Date
Just Received 2nd P3P Pro/Adv Discussion May 29, 2016
received my P3P today, but.... General Discussion Mar 31, 2016
P3 Firmware I received my P3P with very old firmware, should I upgrade? Firmware Oct 18, 2015
Well, I finally received my P3P and Camera View is a no-go... General Discussion Oct 13, 2015
Recently received my Trackimo holder for the P3P! Pro/Adv Discussion Oct 1, 2015