Image transmission and other problems with my p4

Joined
Jul 26, 2017
Messages
1
Reaction score
0
Age
24
Hello everyone !

I got my P4 a few weeks ago and during the 9 flights i've already done so far, i saw a lot of problems that "uglify" my experience.

First of all, i see green and pink bands on my screen everytime. I saw some threads where people said that my phone was not "good" enough (i'm using a LG G3) or that i had to change the transmission quality or change the channel. But the problem is that i cant do that ! in my image transmission settings there is just a chart and i cant click anything.

one of my other problem is that the drone automatically stop filming sometimes. The only thing that i know is that just before it stop, the camera does something strange and i can see the "feet" of the drone on the screen.

and finally i dont know if it's normal or not, but often, my drone goes really slow down. It can go up, right, left, forward or backward real fast but when i wanted to go down he goes really slow and sometimes dont even move.

I would be really happy if someone could help me because i really enjoy flying this thing but these problems are a pain in the neck :sweatsmile:

thanks in advance for reading the problems of a Swiss newbie that cant really speak English

PS : i didnt saw any thread that might have the answers to my questions but i might not have seen everything so if i'm wrong just redirect me to the right thread
 
Joined
Jul 14, 2017
Messages
987
Reaction score
303
You cant downgrade any more, it checked every time you fire it up, and will update again. Strange how some units are affected while others are not.
BQ
 
Joined
Jul 3, 2017
Messages
21
Reaction score
2
Age
22
I downgraded mine, it's explained in that thread
But when I downgraded the Phantoms altitude hold was all over the place and the phantom just dropped out of the sky. No damage
 
Joined
Jul 26, 2017
Messages
6
Reaction score
0
Age
68
Having the same issues, Worked great prior to update! Image trsnsmission lost frequently and seeing the landing foot then recording stops. P4
Just now discovered another glitch 2 file the dates read 12/31/2013 at 11:00am
I file plays and the other not. Next file reads correct then next reads wrong. next 2 are correct.
 
Last edited:
Joined
Jul 3, 2017
Messages
21
Reaction score
2
Age
22
Oh man, this bug is everywhere. So.. There's a bug in the newest firmware that sends the gimbal to a strange position, stops the recording and you lose signal temporarily. Does your Phantom also do this? The date and time is a symptom of this bug
 
Joined
Jul 26, 2017
Messages
6
Reaction score
0
Age
68
I did a couple of things I found to try. Take sd card out and then start everying thing, insert card and format. #2 re-link RC. Did 2 test flights and it seemed good and stable. Of course further testing is needed. I also had a problem with some of new features. Gesture mode would launch active track?? These are things I did not test. Will real soon.
Hope this reslovesmatters. Time will tell
Did longer testing today and the 2 things I did failed, I tried one other thing I read, Switched to 24fps same resolution and I was able to to record a full battery of flight, The 4 records about 9min. and creates a new file which it did flawlessly. If anyone with the image problems could try the same and report back if it work. I did not have any loss of image transmission the entire time.
Going out tomorrow with 4 fully charged batteries and see what happens. Now if I could figure out why I cant do an IMU or compass calibration.
 
Last edited:

New Threads

Members online

No members online now.

Forum statistics

Threads
141,863
Messages
1,458,799
Members
103,650
Latest member
Droneflier1016