Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. Jussaguy

    Jan 19, 2016
    Likes Received:
    Hey guys. So this method was formed by trial and error with anecdotal info from here, RCGroups and the DJI forum. Using this method, I don't think I've found someone that didnt fix the disconnected issue with some iPad and iPhones.

    In the somewhat random looking problem of having the Go App on an IOS tab or phone, there seemed to be no rhyme or reason to it but because there were so many of these "disconnect" issues where it would either give you the "how to connect" of "diaconnected" camera screen, I had discovered a pattern and I am now pretty sure that the problem is seemingly always with an iPhone 6 (any iteration) and an iPad (any iteration) when at first glance it may seem like just the Mini, especially the Mini 2 but the fact is, is that it's just most people flying with that tab. By the way, mine before it permanently disconnected, disconnected from my Mini In mid air and I had to once switch it to ATTI and another time, I just plugged in my working phone.

    The solution is a hodgepodge of solutions that have sometimes worked and sometimes not.

    Here is the method to fix this issue. There have been many methods posted and some (especially the boot from iTunes) seems to fix the issue but I think that's just the long way of getting to this. (Below is a step by step version of the paragraphs)

    If you go to the settings of the Go App on the offended tab or phone app, you should then delete the cache for all of the options.

    The thing I think it is, and I'm just working on hunches and I was waiting to post this until I gathered up all the info for what was working for people and what wasn't, is the firmware cache.

    This just lets the app know, I believe, what firmware you currently have installed for purposes of the app, it does not erase the actual firmwares (app, AC and RC). I can't give you an exact reason but my hunch is there is something happening that is confusing the app as to what firmware it actually has and erasing the cache, deleting the app and re-installing it, re-caches the info and somehow that fixes it.

    I am not techy on the hardware side of things so I'm not sure if the reason I just gave even makes sense, let alone is correct.

    What I am sure of though is that it works.

    Here is what to do if you are having a "disconnected" issue with I'm sure is an iPhone 6 and a IPad laid out in easy to understand instructions:

    1) on the phone or tab that won't connect, go into the settings on the main part of the app and delete all cache (don't worry, we are reinstalling anyway) but we want the firmware cache gone when reinstalled so this assures it will be.

    2) Delete the app.

    3) go to settings of the phone or tab, go to "about" and "erase factory settings and all content". (Back up first to both computer and iCloud if possible. The reason we deleted the app on #2 is because I don't want it to reinstall the app from a restore.

    4) I would personally recommend a clean set up but it's not necessary but either do that or restore from iTunes, not iCloud.

    (The going theory is that the iCloud restore won't work but the direct from iTunes and your computer back up is the way to go and this has been met with some success but not 100%. It is my theory that doing this over an iCloud restore, clears the cache that we already did so this whole step might not even be necessary but I'm not sure so let's just go with what I know has been generally working so restore or "upgrade", to create a new pad or phone. Whichever you want.)

    5) Reinstall the Go App to the "new" device. (Previous firmwares will all be there).

    This should fix the problem and you should be able to connect the craft.

    I want to keep track of how well this is working. I waited until it fixed several people with the issue that were going nuts before I posted this and I would like to keep track so if you had this problem, please post your results (bad or good).

    Good luck!

    #1 Jussaguy, May 2, 2016
    Last edited: May 2, 2016
  2. GoldenHourStudios

    Apr 30, 2017
    Likes Received:
    I am not having any luck with any of the solutions on the forum. I have not flown the drone but one time since last fall and now it boots up and the gimbal runs its warmup but says it is disconnected. The DJI app I used is the original and now has no option for the p4 but the new p4 app does not work. I don't get why this would be changed so much knowing it would create so many issues. The fact that distributors are not even made aware of the changes makes me furious. I should have received some sort of email or info regarding this because we are the first call for the customers and get blind sided by the questions as they come in. My own drone is having a Gimbal Disconnected issue so I am just waiting to get more calls from people who fly theirs as much as i do, like 3 or 4 times a year. I have deleted and reinstalled, Updated firmware to only get stuck at 0% transmission about 30 minutes until the p4 battery goes under 50 then having to change it to another charged one to start the waiting process over again.
  3. wa5tef

    Feb 4, 2017
    Likes Received:
    Saltillo, Mississippi
    Good morning! Yep, I had similar issues with DJI GO app. It kept disconnecting during flight and when I tried to update firmware, I got error stating it would not run on my full size iPad when I was currently running it! I got fed up and bought Litchi and never looked back. You should give it a try, it costs about $23 and is a very small investment considering the drones cost $1,000 +/-. I love creating missions in the Waypoint feature and flying them later, or just making them to measure distances and flight times. I just cannot say enough good things about it. Give it a try.
Similar Threads - fix disconnected App Forum Date
How do I fix a Gimbal Disconnected error? Standard/4k Discussion Apr 16, 2017
Gimbal disconnected after changing antenna to model 7pA can anyone direct me to a fix thanks Phantom 4 Help Sep 30, 2016
Remote Controller battery fixed Phantom 4 Pro Help Today at 10:02 AM
Any news on fixing firmware after last update? Phantom 4 Discussion Tuesday at 7:51 PM
Figured out iOS DJI GO App Map not displaying fix. Control (Go, Litchi, etc..) Aug 7, 2017