Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Grounded Error #29

Discussion in 'Phantom 1 Help' started by kinglou, Jul 29, 2013.

  1. kinglou

    Jun 29, 2013
    Likes Received:
    I took my new phantom out for its fifth flight today and I noticed on take off it was pulling to one side. So I decided it was time to install software / drivers, etc. After doing an advanced calibration (which takes forever..hours?) I get the following error code and 4 red flashes:

    Motors Start failure caused by TX stick(s) mid point error too big
    If the TX stick(s) mid point error is too big, Motors Start will fail when you execute the Combination Stick Commands (CSC) and lead to the aircraft will not takeoff.. And the LED will blink Red four times per second continually to warn you.
    TX stick(s) mid point error too big can be caused by the following reasons:
    (1) There is TX stick (except the throttle stick) not at center when power on the autopilot system.
    (2) The TX sticks has been trimmed, which leads to the large deviation of mid point. For example, the SUB-TRIM has been adjusted for Futaba transmitter.
    (3) The TX stick(s) travel has larger asymmetry.
    For the reason (1), please put all TX sticks at the mid point, and then power cycle the autopilot system to re-record the mid point. If the problem continues, that can be caused by the reason (2) or reason (3), you need to adjust the output range of your TX, and then use the Assistant Software to redo the TX calibration. Please carry out the following procedures.
    (1) Connect to the Assistant software, click Basic-> R/C-> Command Sticks Calibration, and push all TX sticks throughout their complete travel range to see if any stick cannot reach its largest position.
    (2) Adjust the largest travel of TX stick until the cursor on the Assistant software can reach both end positions, according to your TX manual.
    (3) Power cycle the autopilot system, note that power cycle is required.
    (4) Redo the TX calibration according to the Assistant software.

    Im a newb but I tried to figure this out on my own and I am getting very frustrated. I know its probably has to do with the attached screen shot. No matter what I do I cannot get the "T" slider to stick to the center.

    Can anyone come to the rescue?

    Attached Files:

  2. Dskier79

    Jun 30, 2013
    Likes Received:
    There are two tx calibrations. Have you tried doing the tx calibration on the transmitter itself?
  3. runnerman

    Jul 27, 2013
    Likes Received:
    I guess you should contact DJI. I would of recommended you to calibrate... But if you already did that I would just contact DJI.(If you haven't already done so) :(
  4. Hans Groover

    Sep 8, 2013
    Likes Received:
    I'm in the same boat now. I was getting these errors from the green lights, so tried to re-calibrate, nothing happened. Finally bit the bullet and installed NAZA assist and latest firmware. At first all I got was a lot of noise from the Phantom but once I made sure I had the newest version I could see the sticks moving on the NAZA software, but now I'm getting the same error 29 message, meaning that really nothing got fixed, it's still the same as before. I see that it's been a couple of months since you posted this, how did you resolve it?
  5. numair84

    Jan 26, 2015
    Likes Received:
    U probably solved the problem but here goes my fix. I had the same error today. I rebound the rc controller with the dji phantom 2 vision, then connected the controller with my pc and using rc assistant i calibrated the rc controller. That fixed my problem
Similar Threads - Grounded Error #29 Forum Date
Standard I'm pulling my hair out! I'm grounded! Phantom 3 Help Jun 28, 2017
ANOTHER CANADIAN GROUNDED Phantom 4 Help Jun 4, 2017
The Lily Flying camera is permanently grounded News Mar 20, 2017
Grounded P4P HDR Laguna Beach, CA Photos and Video Dec 30, 2016
Fly-away with crash. Plenty of info - please help - grounded :( Phantom 2 Discussion Jun 8, 2016