GPS dropping out, both with Litchi and GO app

Joined
Oct 4, 2016
Messages
51
Reaction score
15
Age
63
I sent my P4A in for repair near the end of my DJI Care Refresh, after a crash on takeoff damaged the housing a bit. I got it back in Jan, did a couple of initial flights with it and all seemed good, one thing I noticed was that the gimbal vibration was completely gone, something my original P4A had bad enough I was getting jello in the videos, but that was corrected more or less after the first time I sent it in, however there was still a bit of vibration.

Anyway, with warmer weather finally here, I did some longer flights yesterday, flying a couple of litchi missions that I have flown before. The first one involves a flight out about 700 meters, circling a POI and returning. It's over a forested area, and when leaves are on the trees I would lose signal when I had the mission set to an altitude of 35 meters, but the mission would complete okay. I then raised the altitude to 100 meters and the signal loss was gone.

Anyway, this time on the way out to the POI, I was getting a couple of GPS errors, then about 1 minute after it circled the POI and was coming in, I got a "mission ended" voice on the Litchi program and I had to come in manually. I then flew another shorter mission I have saved and it aborted about 1 minute in.

I then flew it manually out to the same area with the GO app, I got a couple of GPS out messages, so I flew out an equal distance in another direction, and this time it went into atti mode saying it lost the GPS connection, then picked up the GPS again as I was flying back closer to home.

Today if I get time I am going to fly my P4 on the same missions to see if it happens, but I have a feeling it's only on the P4A as I have never had issues in these areas before.

When I got my P4A back I don't know if I got a replacement unit or not, do they always send a replacement unit when you use the Care Refresh?

If you have issues while using Litchi, will your DJI Care Refresh still apply? I extended mine for another year so I am wondering about that too..

I guess I will open a ticket with DJI and send in my DAT log files & see what they say.
 
Joined
Dec 25, 2016
Messages
1,837
Reaction score
1,100
Location
Tucson, Arizona
If the serial numbers match, that would answer that question.
I’ve heard that if you got a refurbished one, there would be an”r” in the serial number. Personally, I’ve never seen a refurb, so not 100% sure on that aspect.
 
  • Like
Reactions: Hounddog

BudWalker

Premium Pilot
Joined
Jun 24, 2015
Messages
1,448
Reaction score
554
Age
72
Location
Arroyo Grande, California
I sent my P4A in for repair near the end of my DJI Care Refresh, after a crash on takeoff damaged the housing a bit. I got it back in Jan, did a couple of initial flights with it and all seemed good, one thing I noticed was that the gimbal vibration was completely gone, something my original P4A had bad enough I was getting jello in the videos, but that was corrected more or less after the first time I sent it in, however there was still a bit of vibration.

Anyway, with warmer weather finally here, I did some longer flights yesterday, flying a couple of litchi missions that I have flown before. The first one involves a flight out about 700 meters, circling a POI and returning. It's over a forested area, and when leaves are on the trees I would lose signal when I had the mission set to an altitude of 35 meters, but the mission would complete okay. I then raised the altitude to 100 meters and the signal loss was gone.

Anyway, this time on the way out to the POI, I was getting a couple of GPS errors, then about 1 minute after it circled the POI and was coming in, I got a "mission ended" voice on the Litchi program and I had to come in manually. I then flew another shorter mission I have saved and it aborted about 1 minute in.

I then flew it manually out to the same area with the GO app, I got a couple of GPS out messages, so I flew out an equal distance in another direction, and this time it went into atti mode saying it lost the GPS connection, then picked up the GPS again as I was flying back closer to home.

Today if I get time I am going to fly my P4 on the same missions to see if it happens, but I have a feeling it's only on the P4A as I have never had issues in these areas before.

When I got my P4A back I don't know if I got a replacement unit or not, do they always send a replacement unit when you use the Care Refresh?

If you have issues while using Litchi, will your DJI Care Refresh still apply? I extended mine for another year so I am wondering about that too..

I guess I will open a ticket with DJI and send in my DAT log files & see what they say.
I looked at this over on DJI forum.
GPS dropping out on my replaced P4A

post #10

Looks to me like the compass isn't calibrated correctly. Possibly due to an external device being attached and then not doing a calibration.

@sar104
 
Joined
Oct 4, 2016
Messages
51
Reaction score
15
Age
63
Thanks for the replies.

I have not added any external devices such as trackers etc, and did re-calibrate the compass when I got the AC back from DJI. I will re-calibrate compass again and see what happens.

Now that I think about it, I did find it odd that I got the same AC back according to the SN - yet I did pay the $99 replacement fee to DJI for the care refresh. Will have to look into that some more.
 

New Threads

Forum statistics

Threads
140,292
Messages
1,446,257
Members
102,064
Latest member
Nathaniell