Gimbal problems after repair.

Joined
Aug 14, 2018
Messages
20
Likes
2
Age
42
#1
My friends pro crashed and broke the roll arm and ribbon cable. He ordered a kit that came with arms and ribbon cable. I installed the new parts today. The camera works but the gimbal won't move. I can hear the motors beeping but nothing happens. Does anyone have any idea how to fix this? Is there different versions of the ribbon cable?

I am getting "Gimbal roll error" in the DJI app.

Thank you
 
Last edited:
Joined
Jun 30, 2016
Messages
788
Likes
224
Location
PL
#2
My friends pro crashed and broke the roll arm and ribbon cable. He ordered a kit that came with arms and ribbon cable. I installed the new parts today. The camera works but the gimbal won't move. I can hear the motors beeping but nothing happens.
I don't think anyone here knows how to diagnose gimbal issues. If there's no movement at all, then it is possible that gimbal master controller doesn't get data from gyroscoope. Don't know how to check it though.

Is there different versions of the ribbon cable?
No. But there's different qualities. Cheap cables often have issues with video; I haven't heard about issues with gimbal due to cable quality - it requires much less bandwidth.

I am getting "Gimbal roll error" in the DJI app.
Try looking carefully at the roll motor and driver board. Make sure magnet is not broken, and potentiometer gives proper resistance (if it's broken internally, resistance of the outer contacts may change as you rotate it).
 
Joined
Aug 14, 2018
Messages
20
Likes
2
Age
42
#5
Ok. Your talking about the ones glued into the motor case. I wasn't sure if there was something else I missed.
 

New Threads

Forum statistics

Threads
131,661
Messages
1,364,935
Members
96,106
Latest member
kelvynmanuel