Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

FPV loses signal 1-2sec after initialization - Boscam TS352

Discussion in 'FPV (First Person View)' started by vanhoand, Jun 25, 2014.

  1. vanhoand

    Jun 18, 2014
    Likes Received:
    I ran into a new problem with my phantom2 FPV setup yesterday. Hopefully someone can diagnose is with the video I took of the symptoms. Its the Here's the back-story:

    Took the setup to the local hobby shop to pick up some new clover leaf antennas for the FPV system. They only had 2 Rx antennas but said they should still work better than the stock ones that came with the FPV kit. We removed the originals and installed the clovers to compare video quality. Sure enough, they worked better. I removed the clovers and took the system back home. When I got home, I fired up the system and ran it for a minute or two without the antenna installed on the Tx. Also, the original antenna was held on with red loc-tite so there was some residue on the threads which may have prevented me from tightening the clover down all the way after I remembered to put it on.

    Either way, now I'm getting some very shady signal quality. Immediately after start up, I get a signal lock but the quality quickly degrades and then is lost and doesn't come back. Hopefully the youtube video explains it better. In the video, I repeated the process 2x in a row so the behavior is pretty consistent. There's just a quick degradation of signal then its gone...

    I'm trying to figure out if this behavior is symptomatic of a burned up Tx (from when I didn't have the antenna on or not on tight enough) or if something else is going on. After powering the P2 up, the red light on Tx circuit board is lit but the fan doesn't spin (not sure if its supposed to...) The behavior is the same with the original AND new clover antennas so it doesn't appear to be antenna related. (actually while I'm waiting for the video to upload, I found a note for the Tx that says do not remove the stock antenna since its superglued (ie. red loc-tite) on... maybe the connection is damaged??). Thought it might be the gimble ribbon cable but fiddling with that didn't seem to have any affect. I don't have much reason to think its that anyway.

    For reference, the Tx is a Boscam TS352 5.8Ghz 500mw Video Transmitter (part of the Helipal Storm FPV kit).

Similar Threads - FPV loses signal Forum Date
FPV lag, App closes. New question. Phantom 2 Vision Discussion Mar 2, 2014
Phantom4 Realtime FPV feed - Woodland test FPV (First Person View) Friday at 10:48 AM
Phantom4 Realtime FPV feed - Woodland test Photos and Video Aug 13, 2017
Racing/FPV Drones General Discussion Aug 3, 2017
FPV Stutters to the point of being useless Pro/Adv Discussion Jul 29, 2017