Standard Flex cable started to melt immediately on power-up

Joined
Jun 28, 2022
Messages
14
Reaction score
3
Age
43
Following up on my two recent threads, I have a P3S that I bought post-crash. To summarize:
• After I replaced the gimbal arms, roll motor, yaw motor, main control board, and generic flex cable, adjusted the yaw motor shaft by 90°, and jumped out the RC link button, and updated FW, the drone flew, camera worked, and most of the gimbal worked, except for complete lack of camera pitch control. Noticed the ribbon cable trace closest to the face of the roll motor was melted/burned out.
• Replaced DJI flex cable and pitch motor, powered on drone, and the same cable trace *immediately* started to overheat, so I powered down ASAP, and I may have saved the cable.
* Wtf could be causing this? Could I still have a bad motor, or should I try replacing the pitch or roll ESC board(s)? Is there anything I can test on the motors or boards, so that my trial and error doesn’t cost me a $20 cable every time? (Attached photos are the first replacement cable (burned out) and second (overheated and annotated).)
 

Attachments

  • 357F8CE1-B77B-4709-BDF9-30DE453E3C78.jpeg
    357F8CE1-B77B-4709-BDF9-30DE453E3C78.jpeg
    1.8 MB · Views: 37
  • 4DEECBBF-DE78-4690-9FAD-5D5BC706F419.jpeg
    4DEECBBF-DE78-4690-9FAD-5D5BC706F419.jpeg
    595.8 KB · Views: 35
Joined
Jun 28, 2022
Messages
14
Reaction score
3
Age
43
Update: Replaced Roll and Pitch ESC boards, and another DJI ribbon cable, and it initializes and flies fine! No cables melting, and full pitch control! Only remaining issues now are a) camera roll slowly drifts through its full left to right range and back, and b) occasional camera flickers, but I'll start a new thread for those.
 

Recent Posts

Members online

Forum statistics

Threads
142,163
Messages
1,461,135
Members
103,952
Latest member
BryanBrady06