Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Firmware update problem...

Discussion in 'Pro/Adv Discussion' started by Frogbone, Dec 22, 2015.

  1. Frogbone

    Jul 5, 2015
    Likes Received:
    Having a bit of an issue with the firmware update today. Here's my problem: I haven't updated my batteries to the last firmware as my bird crashed just around the time the firmware came out. I received a replacement which had 1.05.0030 on it. Camera on the replacement didn't work right. Today I updated it to today's 1.06.0040. I then tried to update my batteries but got "Battery Error" on each one. I figured it's because I skipped one update on them ?
    Tried to downgrade bird to 1.05.0030 but it did not complete and all I am getting is a very loud beeping from it. Any ideas or thoughts on what I did wrong and what to do now? I am not too concerned about the bird maybe screwed up as It is going back to DJI anyways but I would like my batteries to be all ready to go when my replacement arrives.
Similar Threads - Firmware update problem Forum Date
Problems after P3P v1.11.20 firmware update Pro/Adv Discussion Saturday at 7:03 AM
New firmware update video problems Phantom 4 Discussion Jul 10, 2017
Problem with P3S after recent firmware update Standard/4k Discussion Jul 6, 2017
[RESOLVED] P4P firmware update causes no signal and other problems Phantom 4 Pro Help Jun 26, 2017
Firmware update problem-help! Standard/4k Discussion May 21, 2017