Firmware related gimball tilt when panning?

Joined
Oct 28, 2014
Messages
62
Reaction score
16
Location
Hertfordshire, UK
Hi All,

I've looked over a few posts but cannot see anyone with a similar issue (im hot and tired so maybe it's me),

In a nutshell, when I pan (using left/right motion on right stick), the gimbal tilts 45 degrees laterally and the horison is tilted while panning.

Is the consensus that this is firmware related, or a possbile hardware issue with the gimbal? Im also experencing the 'radar' movement issue so may turn that off in the settings as recommended.

i've done the IMU (and regular compass) resets - does anyone know if the IMU has to be reset for each battery, or is it a onetime per firmware update thing?

cheers in advance!
Matt

Anyway, back to playing with my **** at the airfield (NOT flying the Phantom ;-)) - SEE PIC.
 

Attachments

  • 11709826_10155796311115525_7207958328528380178_n.jpg
    11709826_10155796311115525_7207958328528380178_n.jpg
    85.7 KB · Views: 311
Joined
Oct 28, 2014
Messages
62
Reaction score
16
Location
Hertfordshire, UK
Hi All,

I've looked over a few posts but cannot see anyone with a similar issue (im hot and tired so maybe it's me),

In a nutshell, when I pan (using left/right motion on right stick), the gimbal tilts 45 degrees laterally and the horison is tilted while panning.

Is the consensus that this is firmware related, or a possbile hardware issue with the gimbal? Im also experencing the 'radar' movement issue so may turn that off in the settings as recommended.

i've done the IMU (and regular compass) resets - does anyone know if the IMU has to be reset for each battery, or is it a onetime per firmware update thing?

cheers in advance!
Matt

Anyway, back to playing with my **** at the airfield (NOT flying the Phantom ;-)) - SEE PIC.

Ok, my bad, literally the post before mine talked about a similar issue while 'Banking'...looks like firmware.
 
Joined
Aug 8, 2014
Messages
389
Reaction score
81
Probably not why, but Make sure you are not in FPV flight mode which will fly with a banking type camera motion.... In the app settings. I did this by accident by hitting the button on the bottom of the RC by ac I den.

Sent from my SM-G920V using Tapatalk
 
Joined
Jun 25, 2015
Messages
36
Reaction score
37
Age
36
Hi All,

I've looked over a few posts but cannot see anyone with a similar issue (im hot and tired so maybe it's me),

In a nutshell, when I pan (using left/right motion on right stick), the gimbal tilts 45 degrees laterally and the horison is tilted while panning.

Is the consensus that this is firmware related, or a possbile hardware issue with the gimbal? Im also experencing the 'radar' movement issue so may turn that off in the settings as recommended.

i've done the IMU (and regular compass) resets - does anyone know if the IMU has to be reset for each battery, or is it a onetime per firmware update thing?

cheers in advance!
Matt

Anyway, back to playing with my **** at the airfield (NOT flying the Phantom ;-)) - SEE PIC.


I had the exact same issue in 1.1.9. Good news is that 1.2.6 fixed that. Bad news is that it unleashed pandora's box with a slew of other problems. That problem is 100% firmware related.
 

TAZ

Joined
Jun 11, 2015
Messages
186
Reaction score
121
This is not a typical firmware issue. I'd agree with the first response, check your flight mode...easily mistakenly changed to FPV vs Follow. Some have experienced a seeming FPV lock, that an IMU calibration fixed. More info here: http://forum.dji.com/thread-14780-1-1.html
 
Joined
Oct 28, 2014
Messages
62
Reaction score
16
Location
Hertfordshire, UK
This is not a typical firmware issue. I'd agree with the first response, check your flight mode...easily mistakenly changed to FPV vs Follow. Some have experienced a seeming FPV lock, that an IMU calibration fixed. More info here: http://forum.dji.com/thread-14780-1-1.html
Many thanks, will give that a go too.

Do you know if you have to do an IMU calibration for each battery? Trying to determine if the tilt only happens with one of my batteries and not the other but keep forgetting to write down which battery i used! (I numbered them).

cheers,
Matt
 

New Threads

Forum statistics

Threads
140,602
Messages
1,449,217
Members
102,408
Latest member
V8starlet