Fat Shark Battery

Joined
Jul 28, 2016
Messages
316
Reaction score
71
Age
61
What does it mean when only the two end lights only work? The two in the middle nothing. Is it time for a new one? I hardly used this one at all
 
Joined
May 1, 2017
Messages
2,569
Reaction score
1,677
Age
66
Location
N.central wv. U.S.
Do the cells have good voltage readings? When it's in operation does the battery show a 100% charge, even with two lights working? Maybe the wires came loose?
 
Joined
Dec 12, 2016
Messages
286
Reaction score
102
Location
Md
This would probably be better posted over at DRP instead of the Phantom group, but since I am in both I happened to see this. If you do mean the Fatshark goggle battery I would think that 2 of the LED's are the issue, check the voltage with a voltmeter or a simple battery checker on the 2s JST connector. Even though it is not a real 2s connection, it is missing a wire, but most simple checkers will read cell #2 as the full 2s battery voltage.

If on the other hand you mean a Phantom battery, then I think that could be real trouble for that battery.
 
Joined
Jul 28, 2016
Messages
316
Reaction score
71
Age
61
First I haven’t tried the battery in the goggles I was just getting ready for this weekend and second it is the battery to the fat shark
 
Joined
Jul 28, 2016
Messages
316
Reaction score
71
Age
61
I did find a battery tester it said 2 cell 1at 7.4 1at 0.5
Is this batter done or can it be saved?
 
Joined
Dec 12, 2016
Messages
286
Reaction score
102
Location
Md
@Ed Hahn, that is a completely normal reading from a Fatshark battery. Since the 2s balance connector only has 2 wires instead of 3 it is impossible for the battery tester to read the separate cells. It will always read one as almost 0 volts and the other as double the cell voltage. It sounds like the battery itself is fine, if the LED's don't work correctly it wont affect the operation of the battery at all.
 
Joined
Aug 16, 2019
Messages
14
Reaction score
1
Age
18
If in operation it shows all the batteries as being good then the leds are probably just faulty. So not an issue
 
Joined
Jul 28, 2016
Messages
316
Reaction score
71
Age
61
I did get out this weekend and it worked find. One question what do you mean (in operation it shows all good) Is there someplace that shows you the battery % of the glasses? I could dot see anything like that.
 

New Threads

Forum statistics

Threads
136,089
Messages
1,407,531
Members
99,034
Latest member
farjot