Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Controller firmware update failed, not turning on anymore!

Discussion in 'Pro/Adv Discussion' started by butchmarzee, Sep 24, 2016.

  1. butchmarzee

    Sep 24, 2016
    Likes Received:
    hi guys,

    im new here, and need some help if its impossible at all.
    the story is:
    the drone crashed nearly a year ago, and the camera broke off. the phantom still was able to fly, but i lost the interest and didnt want to spend 300£+ for a new camera, so the drone spent the last year on the shelf.
    last week i decided to fix it, so i charged everything up (batteries still had charge, as i stored charged), and tried to fire up.
    drone turned on, controller turned on, but red led lighted as not connected to drone. ok, need to pair again after this long time, its fine.
    i hooked up the controller to the ipad, but dji go didnt see the controller attached. I deleted the app, reinstall, tried with different phones, etc, no luck. I hooked up to my mac, dji assistant saw the controller, said firmware can be updated to 1.6 or whatever. started to update, around 40-50 percent it stoped, said failed. tried redo, didnt start the upgrade at all. since the controller cant turn on, just the leds lighting as normal, but no beeping, and the hard reset button combinations dont work either. looks like the assist deleted the previous firmware and now there is no firmware at all, just the blank hardware with the battery control system.
    I dont know why the dji didnt put a just readable, recoverable basic firmware for these situations?

    any ideas if i could do something, or it became an expensive crap ??
    ah yeah, model: gl300A
    thanks for any help guys, i have read the internet already, but didnt find similar problem
  2. alokbhargava

    Sep 28, 2015
    Likes Received:
    San Francisco, CA
    I'm not sure what happened during FW upgrade. Did your RC had enough juice to carry through?

    1.6 FW for RC is a very critical FW. It will need AC also to be upgraded. Normal procedure is to upgrade AC first with RC off and then upgrade RC with AC off

    If you don't want to go through all this hassle, downgrade RC to the previous FW.

    Sent from my iPhone using PhantomPilots
  3. butchmarzee

    Sep 24, 2016
    Likes Received:
    the problem is nothing recognize the controller anymore if i plug it via any of the 2 usb ports.
Similar Threads - Controller firmware update Forum Date
Standard GL 358 wA controller firmware update Phantom 3 Help Dec 27, 2017
Controller firmware update, advice required please Phantom 4 Help Nov 12, 2017
Updated firmware and now I get a Remote Controller Weak Signal message Firmware Sep 23, 2017
Weak controller signal after latest firmware update Phantom 4 Pro Discussion Jun 12, 2017
My Phanton 3 pro Controller won't update to latest firmware is there a genuine fix? Pro/Adv Discussion Jan 5, 2017