Controller Camera Button Strange Behavior

Joined
Mar 28, 2014
Messages
18
Reaction score
4
Location
San Diego, CA
Website
www.pbkimages.com
On my P4P, I have noticed that when pressing the camera button for still shots (not Video) located on the controller, (not the screen monitor) sometimes the image is not recorded. Here are the different conditions:
1. ACTION: Press shutter button displayed on IPAD SCREEN. RESULT: white shutter button ring rotates and you hear the shutter click sound, image is captured. Always works correctly when using screen displayed button.
2. ACTION: Press unmarked designated shutter button on right front side of controller (as you look down on controller). DIFFERENT RESULTS: (a) 30% of time--normal results like #1 above.
(b) 30% of time, white ring fills in, NO shutter click sound, and image is captured. (c) 40% of time, white ring fills in, NO shutter click sound, and image is NOT captured. This happens randomly.
Has anyone experienced this strange behavior? Distance from controller to drone is not a factor, nor is interference. So unless you use the screen shutter button, which is inconvenient if you are using a hood, then you are not sure if you actually captured your shot unless you take valuable time to check playback. This may have something to do with the camera not focusing when the shutter button is pressed, and therefore it does not capture the shot. But why just for the controller button when the display button works fine?
Thanks for any advice.

Skydriver
 
Joined
Jun 11, 2016
Messages
213
Reaction score
80
Location
Mendocino CA
Website
www.nwilsonphoto.com
I'm having the same issue with my P4A+ for both video and still shooting. Sometimes there seems to be no response to the shutter or record button, but it actually captures a shot or video, and I only know afterwards when I review what's on the memory card. There are times I have had to bring the drone back to base and restart both the drone and the RC in an effort to correct it, and that doesn't always work.

UPDATE: The problem was with the SD card. While flying I heard a faint voice from the controller, and when I turned up the volume it was telling me that there was an error with the SD card "please replace it." I tried formatting the card in the drone, and after that the problem was fixed; no more problems shooting stills or video.
 
Last edited:
Joined
Mar 28, 2014
Messages
18
Reaction score
4
Location
San Diego, CA
Website
www.pbkimages.com
Sounds very similar. I talked to Customer Service and their only advise was to send it in. When you do that you always take a chance. There has been no firmware upgrades for months.
 
Joined
Mar 26, 2018
Messages
18
Reaction score
5
Age
55
I've had the same issue with my P4P, for a while now. It makes no sound or anything i thought it was the distance between the two, but even flying overhead same thing some times.
I have noticed also I'll get magnetic interference with compass.
What i have found out that if my Samsung 10 tablet has a low battery that will happen
 
Joined
Mar 28, 2014
Messages
18
Reaction score
4
Location
San Diego, CA
Website
www.pbkimages.com
I am using an Apple iPad fully charged and this problem happens all the time using the CONTROLLER button. It works fine using the virtual button on the control screen.
 

New Threads

Forum statistics

Threads
133,050
Messages
1,378,332
Members
97,142
Latest member
4evermy