Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Can't get dji go app to work

Discussion in 'Standard' started by mcg024, May 17, 2018.

  1. mcg024

    Joined:
    May 17, 2018
    Messages:
    1
    Likes Received:
    0
    Whats up all? I have a question I know i can get answered here. I'm flying or trying to fly the phantom3 standard. I'm on a film shoot and tried to use the drone to get a shot. Problem is that when i tried to use the dji go app it wants me to sign up or log in. Well, i never had to create an account to use it before so i have to create one. Next problem is that it asks for a phone number in main land China. How do i get around this problem to get the drone running so i can get back to work. Thanks in advance.
     
  2. Waylander

    Joined:
    Jul 14, 2015
    Messages:
    467
    Likes Received:
    137
    Location:
    West Yorkshire, UK
    Hi mcg024

    Very sorry my friend, I think you are screwed, along with the PC correct brigade, everyone else including DJI are protecting their A###'s alleging Data Protection has forced them to do it.
    So now you must log on to an account in order to use DJI go or DJI go4 app.
    Why not use Litchi to fly your drone, no need to log on to them

    Anti-Establishment rant

    Waylander
     
Loading...
Similar Threads - Can't dji app Forum Date
Standard Can't connect to dji go app Phantom 3 Help May 5, 2018
Can't connect DJI repaired AC to App or IOS Phantom 4 Pro Help Mar 4, 2018
Can't sign in to dji go 4 app Control (Go, Litchi, etc..) Oct 1, 2017
DJI Go 4 App updated . Can't log in Phantom 4 Pro Help Jun 8, 2017
Can't access pictures from the dji go app Standard Jan 29, 2017