Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Firmware Update preoblems 1.8.8 RC not working now.

Discussion in 'Firmware' started by lomax, May 14, 2016.

  1. lomax

    Aug 11, 2015
    Likes Received:
    Westminster Colorado
    I guess it is my turn to ask for help. I have had my Phantom 3P for over a year and have done many software updates with no issues. Here is what happens when trying to upgrade to the latest software. Sorry about the spelling in the title, long morning already. :rolleyes:

    I am updating from the last release of 1.7.60 where everything worked just fine.

    Downloaded P3X_FW-V01.08.0080.zip file from DJI site and extracted for a 64.544kb bin file.
    File P3X_FW-V01.08.0080.bin has been loaded to the SD card.

    SD card into the P3P and turn it on. Camera light does its proper thing of flashing red and green and it does complete with the green light and the D-DD. The TXT file on the card show success so as far as I can tell the P3P itself has updated properly. I have turned the P3P off per instructions.

    On my Ipad mini 2 which I have used from the beginning I updated the DJI GO app from the app store. so it is the latest.

    Per instructions I now turn on the RC, connect RC to tablet, Turn on tablet connected to internet, launch DJI GO app, enter camera view. There is no notice to update RC only aircraft disconnected on the top line. Light is red on RC.

    So start aircraft and overall status screen comes up and RC light turns green. Still no update required notification. When X-ing out of aircraft status screen the header just reads RC Signal lost.

    I have tried putting the SD card in the card reader and in the RC slot and also tried the method of putting the SD card in the P3P and connecting it to the RC with the USB cable. The light on the RC stays Red and no update occurs.

    I tried downgrading back to 1.7.60 and get the same error.

    Can this mean the RC is updated OK ?

    The only thing I can think of is that I need to rebind the RC to the P3P but have never had to do this before and cannot find out how to do it. I will search more on this but any information, instructions, or a link to rebinding would be greatly appreciated. IF this is even the problem.

    OK stupid me, I will keep updating in the hopes this helps someone else out.

    I found how to relink/bind the RC and the P3P. Under the RC menu in the Go app towards the bottom is linking RC button. Press this and it will begin a countdown. Then locate the link button on the P3P itself and press. This worked fine one I found where I put my user manual. DOH sorry old age mistake. :confused: The bird is now in the fridge to get it cold for IMU calibration. After that I will calibrate the compass and see if I have full control over it again.

    OK after doing the IMU calibration it is back to RC signal lost. I tried linking again with no results. This is with the RC sitting right next to the P3P. SO I am back in the same boat as when this started that I cannot link the P3P and the RC. Please help if possible.

    Thanks in advance.

    #1 lomax, May 14, 2016
    Last edited: May 14, 2016
    Mromansea likes this.
  2. Mromansea

    Jan 13, 2014
    Likes Received:
    Same problem here. Was asked to do the upgrade, despite several other bad experiences with DJI upgrades, went ahead and did it. Now my DJI P3 Pro is a white brick. Anyone know the magic sequence to "unbrick" my friggin' bird? So irritated with these guys I can hardly see straight...
  3. Fat Daddy

    May 14, 2016
    Likes Received:
    I just purchased the P3P (got it Friday) and did the upgrade on the multi-rotor just fine. Downloaded the Go app and I get just what the original poster describes. Called support and they want me to send the controller in for service. I think I'll wait. This may be a firmware problem.

    Sent from my iPhone using PhantomPilots mobile app
Similar Threads - Update preoblems working Forum Date
Phantom 4 pro gimbal buzzes after newest firmware update Phantom 4 Pro Discussion Today at 9:49 AM
update issues Phantom 4 Discussion Yesterday at 7:01 PM
Update or not? Pro/Adv Discussion Monday at 3:30 PM
Newest update not taking with P3A Pro/Adv Discussion Sunday at 9:23 PM
Beeping loop after update failure. Can't update drone anymore Phantom 4 Help Sunday at 10:19 AM