RC NOT POWERING UP F I X

P3P

Joined
Jan 2, 2019
Messages
15
Reaction score
4
Age
42
I carried my P3P4K from one end of the globe to Europe in order to discover after 1 week of no usage (battery was fully charged) that the RC won't turn on.
Charging was of no use so I took it apart and lo and behodl the GPS antenna module was... Warm as well as the LED GP1012 was blinking green light.
The battery was warm too, like slowly being drained. I installed Argtek antennas about 1 month ago by the book, no damage done to the RC whatsoever I wouldn't think the antennas could drain the battery?!
I plugged the battery back in and lo and behold... The frigging thing works again.
If this helps anybody, mission accomplished.


Tools to undo the RC
Phillips head #1
Allen Key Th#6
Flat screw driver to pry out the small lid.

IMG_20190217_081939.jpeg
 

P3P

Joined
Jan 2, 2019
Messages
15
Reaction score
4
Age
42
I believe I had it charged at 100% and by default it would start discharging hence it was warm. When churger plugged in, nothing will happen.
The weird thing was that it wouldn't turn on either.
The previous owner warned me that whenever it would freeze, I should disconnect the battery.
Maybe this is what he was warning me about.
 
  • Like
Reactions: MotorCycle-Man
Joined
Jun 7, 2019
Messages
4
Reaction score
5
Age
66
That's exactly what mine was doing, see my solution in a separate thread. Also if you notice, you will still have the Phantom wifi connection on your phone, when the RC won't power up and that small led is on inside.
 

New Threads

Forum statistics

Threads
134,499
Messages
1,391,348
Members
98,044
Latest member
gknaps