Problem with ESC or motor

Joined
Dec 10, 2016
Messages
5
Reaction score
0
Age
35
Hi all,

I need your help:)

I bought my P2V+ and everything works fine..today i make some great videos.

But not the all blades are spinning like they should. When i turned off the motors there is one of these which turn off a little bit earlier.

And also when i start Phantom the ESC LED on one of these motors is turned off, but when i add a little bit throttle the LED its on !!!

anyway, like i said, the flying is fine..no problem at all..

can you please help me or give me some advice?

thank you very much

Andrej

PS: my english is bad...sorry for that
 

Mark The Droner

Premium Pilot
Joined
Aug 26, 2015
Messages
5,311
Reaction score
1,740
My AC was like yours. One of the props would spin better or more free than the others. But it flew fine and I never had a problem.

Re the lamps, when you first start up the AC, all four wing lamps will light up during the boot process. After the boot process, the front lamps will turn off and remain off while the rear lamps will flash normally per the manual.

When you start the motors and leave the motor in idle, the front lamps will remain off.

When you spin the motors slightly above idle, the front lamps will light up solid red and they will stay solid red until your flight is over. This is normal.

Hope this helps.
 
Joined
Dec 10, 2016
Messages
5
Reaction score
0
Age
35
Thanks !! I make a video about my problem. But like you said..its normal:)..thanks again

 

Mark The Droner

Premium Pilot
Joined
Aug 26, 2015
Messages
5,311
Reaction score
1,740
It's strange that when starting the motors your left front lamp turns red while the right front lamp stays off. That's unusual. Normally both would either stay off together or go on together. I don't know why you'd have one on and the other off.
 
Phantom Drones from EALLRC.com

New Threads

Forum statistics

Threads
136,720
Messages
1,413,764
Members
99,384
Latest member
mykee